aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/anyremote2html/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/anyremote2html/Makefile b/www/anyremote2html/Makefile
index 8724c10aa473..167cba4a9f99 100644
--- a/www/anyremote2html/Makefile
+++ b/www/anyremote2html/Makefile
@@ -9,19 +9,22 @@ MASTER_SITES= SF/anyremote/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Web interface for anyRemote
-RUN_DEPENDS= anyremote:comms/anyremote
-
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+RUN_DEPENDS= anyremote:comms/anyremote
+
GNU_CONFIGURE= yes
-USES= python:run
+USES= python:run shebangfix
+SHEBANG_FILES= anyremote2html
+NO_ARCH= yes
-PORTDOCS= ChangeLog README COPYING AUTHORS
+PORTDOCS= ChangeLog README AUTHORS
OPTIONS_DEFINE= DOCS
post-patch:
+ @${REINPLACE_CMD} -e 's|COPYING||g' ${WRKSRC}/Makefile.*
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' ${WRKSRC}/${PORTNAME}
.include <bsd.port.mk>