aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-openapi-spec-validator/Makefile31
-rw-r--r--devel/py-openapi-spec-validator/distinfo3
-rw-r--r--devel/py-openapi-spec-validator/pkg-descr5
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 18201b3e9022..39e12e8708ed 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4647,6 +4647,7 @@
SUBDIR += py-omnijson
SUBDIR += py-omniorb
SUBDIR += py-openapi-codec
+ SUBDIR += py-openapi-spec-validator
SUBDIR += py-opendht
SUBDIR += py-opengrok-tools
SUBDIR += py-openstacksdk
diff --git a/devel/py-openapi-spec-validator/Makefile b/devel/py-openapi-spec-validator/Makefile
new file mode 100644
index 000000000000..fc3699890086
--- /dev/null
+++ b/devel/py-openapi-spec-validator/Makefile
@@ -0,0 +1,31 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= openapi-spec-validator
+PORTVERSION= 0.2.7
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Validator for OpenAPI 2.0 and 3.0.0 specification
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=5.1:devel/py-yaml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pathlib2>=0:devel/py-pathlib2@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-openapi-spec-validator/distinfo b/devel/py-openapi-spec-validator/distinfo
new file mode 100644
index 000000000000..04b92331797b
--- /dev/null
+++ b/devel/py-openapi-spec-validator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1561317099
+SHA256 (openapi-spec-validator-0.2.7.tar.gz) = 77c4fb47fe8a7dd527c7433861638221eb416827dc1c5c983505c0a38ca6e9eb
+SIZE (openapi-spec-validator-0.2.7.tar.gz) = 22042
diff --git a/devel/py-openapi-spec-validator/pkg-descr b/devel/py-openapi-spec-validator/pkg-descr
new file mode 100644
index 000000000000..dbb8df6b5175
--- /dev/null
+++ b/devel/py-openapi-spec-validator/pkg-descr
@@ -0,0 +1,5 @@
+OpenAPI Spec Validator is a Python library that validates OpenAPI Specs against
+the OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0.0 specification. The validator
+aims to check for full compliance with the Specification.
+
+WWW: https://github.com/p1c2u/openapi-spec-validator