aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/p5-DNS-Zone/Makefile13
-rw-r--r--dns/p5-DNS-Zone/pkg-descr3
-rw-r--r--dns/p5-DNS-Zone/pkg-plist24
-rw-r--r--net/p5-DNS-Zone/Makefile13
-rw-r--r--net/p5-DNS-Zone/pkg-descr3
-rw-r--r--net/p5-DNS-Zone/pkg-plist24
6 files changed, 38 insertions, 42 deletions
diff --git a/dns/p5-DNS-Zone/Makefile b/dns/p5-DNS-Zone/Makefile
index dc597ec254e7..fa5672fca681 100644
--- a/dns/p5-DNS-Zone/Makefile
+++ b/dns/p5-DNS-Zone/Makefile
@@ -18,7 +18,10 @@ COMMENT= DNS::Zone is set of perl modules for name service zone files
PERL_CONFIGURE= yes
-DOCSDIR= ${PREFIX}/share/doc/p5-DNS-Zone
+post-patch:
+ ${FIND} ${WRKSRC} -name '*.pm' -o -name '*.t' -o -name '*.PL' | \
+ ${XARGS} ${PERL} -pi -e '$$_="" if /^use 5/;' \
+ -e '$$_="" if /(use|no) warnings/;'
post-install:
.if !defined(NOPORTDOCS)
@@ -26,10 +29,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/p5-DNS-Zone/pkg-descr b/dns/p5-DNS-Zone/pkg-descr
index 305d1af4de10..19c3780bbd8a 100644
--- a/dns/p5-DNS-Zone/pkg-descr
+++ b/dns/p5-DNS-Zone/pkg-descr
@@ -5,5 +5,6 @@ The modules origin is the ZoneMaster project which make heavy
use of the module for comprehensive zone file management. Go to
http://www.zonemaster.org for further information.
-WWW: http://search.cpan.org/author/WOLF/
+WWW: http://search.cpan.org/dist/DNS-Zone/
+
Author: Andy Wolf <zonemaster@users.sourceforge.net>
diff --git a/dns/p5-DNS-Zone/pkg-plist b/dns/p5-DNS-Zone/pkg-plist
index 04e97e8cc680..994ca3850915 100644
--- a/dns/p5-DNS-Zone/pkg-plist
+++ b/dns/p5-DNS-Zone/pkg-plist
@@ -1,12 +1,12 @@
-lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DNS-Zone/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/Label.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/Record.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File/Default.pm
-%%PORTDOCS%%share/doc/p5-DNS-Zone/README
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DNS-Zone
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone
-@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DNS 2>/dev/null || true
-%%PORTDOCS%%@dirrm share/doc/p5-DNS-Zone
+%%SITE_PERL%%/DNS/Zone.pm
+%%SITE_PERL%%/DNS/Zone/File.pm
+%%SITE_PERL%%/DNS/Zone/File/Default.pm
+%%SITE_PERL%%/DNS/Zone/Label.pm
+%%SITE_PERL%%/DNS/Zone/Record.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS-Zone/.packlist
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS-Zone
+@dirrm %%SITE_PERL%%/DNS/Zone/File
+@dirrm %%SITE_PERL%%/DNS/Zone
+@unexec rmdir %D/%%SITE_PERL%%/DNS 2>/dev/null || true
diff --git a/net/p5-DNS-Zone/Makefile b/net/p5-DNS-Zone/Makefile
index dc597ec254e7..fa5672fca681 100644
--- a/net/p5-DNS-Zone/Makefile
+++ b/net/p5-DNS-Zone/Makefile
@@ -18,7 +18,10 @@ COMMENT= DNS::Zone is set of perl modules for name service zone files
PERL_CONFIGURE= yes
-DOCSDIR= ${PREFIX}/share/doc/p5-DNS-Zone
+post-patch:
+ ${FIND} ${WRKSRC} -name '*.pm' -o -name '*.t' -o -name '*.PL' | \
+ ${XARGS} ${PERL} -pi -e '$$_="" if /^use 5/;' \
+ -e '$$_="" if /(use|no) warnings/;'
post-install:
.if !defined(NOPORTDOCS)
@@ -26,10 +29,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-DNS-Zone/pkg-descr b/net/p5-DNS-Zone/pkg-descr
index 305d1af4de10..19c3780bbd8a 100644
--- a/net/p5-DNS-Zone/pkg-descr
+++ b/net/p5-DNS-Zone/pkg-descr
@@ -5,5 +5,6 @@ The modules origin is the ZoneMaster project which make heavy
use of the module for comprehensive zone file management. Go to
http://www.zonemaster.org for further information.
-WWW: http://search.cpan.org/author/WOLF/
+WWW: http://search.cpan.org/dist/DNS-Zone/
+
Author: Andy Wolf <zonemaster@users.sourceforge.net>
diff --git a/net/p5-DNS-Zone/pkg-plist b/net/p5-DNS-Zone/pkg-plist
index 04e97e8cc680..994ca3850915 100644
--- a/net/p5-DNS-Zone/pkg-plist
+++ b/net/p5-DNS-Zone/pkg-plist
@@ -1,12 +1,12 @@
-lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DNS-Zone/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/Label.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/Record.pm
-lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File/Default.pm
-%%PORTDOCS%%share/doc/p5-DNS-Zone/README
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/DNS-Zone
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone/File
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/DNS/Zone
-@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DNS 2>/dev/null || true
-%%PORTDOCS%%@dirrm share/doc/p5-DNS-Zone
+%%SITE_PERL%%/DNS/Zone.pm
+%%SITE_PERL%%/DNS/Zone/File.pm
+%%SITE_PERL%%/DNS/Zone/File/Default.pm
+%%SITE_PERL%%/DNS/Zone/Label.pm
+%%SITE_PERL%%/DNS/Zone/Record.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS-Zone/.packlist
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS-Zone
+@dirrm %%SITE_PERL%%/DNS/Zone/File
+@dirrm %%SITE_PERL%%/DNS/Zone
+@unexec rmdir %D/%%SITE_PERL%%/DNS 2>/dev/null || true