aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/libtelepathy/Makefile2
-rw-r--r--net-im/telepathy-butterfly/Makefile2
-rw-r--r--net-im/telepathy-farsight/Makefile2
-rw-r--r--net-im/telepathy-farstream/Makefile2
-rw-r--r--net-im/telepathy-gabble/Makefile2
-rw-r--r--net-im/telepathy-glib/Makefile2
-rw-r--r--net-im/telepathy-idle/Makefile2
-rw-r--r--net-im/telepathy-logger/Makefile2
-rw-r--r--net-im/telepathy-rakia/Makefile2
-rw-r--r--net-im/telepathy-salut/Makefile2
10 files changed, 10 insertions, 10 deletions
diff --git a/net-im/libtelepathy/Makefile b/net-im/libtelepathy/Makefile
index 71b7093c9030..7f75c8e32089 100644
--- a/net-im/libtelepathy/Makefile
+++ b/net-im/libtelepathy/Makefile
@@ -14,7 +14,7 @@ COMMENT= Flexible Communications Framework
LIB_DEPENDS= libtelepathy-glib.so:net-im/telepathy-glib \
libdbus-glib-1.so:devel/dbus-glib
-USES= gmake libtool pathfix pkgconfig python:build
+USES= gmake libtool pathfix pkgconfig python:2,build
USE_LDCONFIG= yes
USE_GNOME= glib20 libxslt:build
GNU_CONFIGURE= yes
diff --git a/net-im/telepathy-butterfly/Makefile b/net-im/telepathy-butterfly/Makefile
index 63e6e5e76d21..3b422663152f 100644
--- a/net-im/telepathy-butterfly/Makefile
+++ b/net-im/telepathy-butterfly/Makefile
@@ -18,6 +18,6 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/papyon/__init__.py:net-im/papyon \
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${PREFIX}
-USES= gmake python
+USES= gmake python:2
.include <bsd.port.mk>
diff --git a/net-im/telepathy-farsight/Makefile b/net-im/telepathy-farsight/Makefile
index dd543547b3e9..9662f6cc0e95 100644
--- a/net-im/telepathy-farsight/Makefile
+++ b/net-im/telepathy-farsight/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libgstfarsight-0.10.so:net-im/farsight2
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig python
+USES= gmake libtool pathfix pkgconfig python:2
USE_LDCONFIG= yes
USE_GNOME= glib20 libxslt:build
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net-im/telepathy-farstream/Makefile b/net-im/telepathy-farstream/Makefile
index de3d3710d0c4..d67ee7029f86 100644
--- a/net-im/telepathy-farstream/Makefile
+++ b/net-im/telepathy-farstream/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libtelepathy-glib.so:net-im/telepathy-glib \
libfarstream-0.2.so:net-im/farstream
-USES= gmake libtool pathfix pkgconfig python
+USES= gmake libtool pathfix pkgconfig python:2
USE_GNOME= glib20 libxslt:build introspection:build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index db27193595cf..efcf6d2781ec 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
PORTSCOUT= limitw:1,even
-USES= alias gmake libtool pathfix pkgconfig python:build sqlite
+USES= alias gmake libtool pathfix pkgconfig python:2,build sqlite
USE_GNOME= glib20 gtksourceview3 libxslt:build
USE_OPENSSL= yes
GNU_CONFIGURE= yes
diff --git a/net-im/telepathy-glib/Makefile b/net-im/telepathy-glib/Makefile
index ef82ca49dec0..e9e88753c7cd 100644
--- a/net-im/telepathy-glib/Makefile
+++ b/net-im/telepathy-glib/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= vapigen:lang/vala
PORTSCOUT= limitw:1,even
-USES= gmake libtool pathfix pkgconfig python:build
+USES= gmake libtool pathfix pkgconfig python:2,build
USE_GNOME= glib20 introspection:build libxslt:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net-im/telepathy-idle/Makefile b/net-im/telepathy-idle/Makefile
index 866712692958..1664b545a8ac 100644
--- a/net-im/telepathy-idle/Makefile
+++ b/net-im/telepathy-idle/Makefile
@@ -14,7 +14,7 @@ COMMENT= IRC Connection Manager for Telepathy Framework
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libtelepathy-glib.so:net-im/telepathy-glib
-USES= execinfo gmake libtool pathfix pkgconfig python:build
+USES= execinfo gmake libtool pathfix pkgconfig python:2,build
USE_GNOME= glib20 libxslt:build
GNU_CONFIGURE= yes
USE_OPENSSL= yes
diff --git a/net-im/telepathy-logger/Makefile b/net-im/telepathy-logger/Makefile
index 5d5538a91e25..030fd7ce2668 100644
--- a/net-im/telepathy-logger/Makefile
+++ b/net-im/telepathy-logger/Makefile
@@ -16,7 +16,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libtelepathy-glib.so:net-im/telepathy-glib
-USES= gettext-tools gmake libtool pathfix pkgconfig python:build \
+USES= gettext-tools gmake libtool pathfix pkgconfig python:2,build \
sqlite tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net-im/telepathy-rakia/Makefile b/net-im/telepathy-rakia/Makefile
index 4135c9270daa..a35426f66625 100644
--- a/net-im/telepathy-rakia/Makefile
+++ b/net-im/telepathy-rakia/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libsofia-sip-ua-glib.so:net/sofia-sip \
libtelepathy-glib.so:net-im/telepathy-glib
-USES= gmake pathfix pkgconfig python:build
+USES= gmake pathfix pkgconfig python:2,build
USE_GNOME= glib20 libxslt:build
GNU_CONFIGURE= yes
USE_OPENSSL= yes
diff --git a/net-im/telepathy-salut/Makefile b/net-im/telepathy-salut/Makefile
index 0986e565ef0c..df7e8d053109 100644
--- a/net-im/telepathy-salut/Makefile
+++ b/net-im/telepathy-salut/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libavahi-glib.so:net/avahi-app \
libsoup-2.4.so:devel/libsoup
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig python:build sqlite
+USES= gmake libtool pathfix pkgconfig python:2,build sqlite
USE_GNOME= glib20 libxslt:build
USE_OPENSSL= yes
CONFIGURE_ARGS= --disable-Werror --enable-avahi-tests=no