aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--sysutils/spiped/Makefile6
-rw-r--r--sysutils/spiped/distinfo6
-rw-r--r--sysutils/spiped/files/spiped.in7
5 files changed, 15 insertions, 8 deletions
diff --git a/GIDs b/GIDs
index bffbc78d258e..f190855651a6 100644
--- a/GIDs
+++ b/GIDs
@@ -199,7 +199,7 @@ _i2pd:*:255:
_tor:*:256:
_smtpd:*:257:
_smtpq:*:258:
-# free: 259
+spiped:*:259:
meta1s:*:260:
meta1q:*:261:
meta1c:*:262:meta1s
diff --git a/UIDs b/UIDs
index f2a194d3cb39..a9f3ddd19094 100644
--- a/UIDs
+++ b/UIDs
@@ -204,7 +204,7 @@ _i2pd:*:255:255::0:0:I2P daemon:/var/db/i2pd:/usr/sbin/nologin
_tor:*:256:256::0:0:Tor anonymizing router:/var/db/tor:/usr/sbin/nologin
_smtpd:*:257:257::0:0:OpenSMTPD:/var/empty:/usr/sbin/nologin
_smtpq:*:258:258::0:0:OpenSMTPD queue user:/var/empty:/usr/sbin/nologin
-# free: 259
+spiped:*:259:259::0:0:spiped user:/nonexistent/:/usr/sbin/nologin
meta1s:*:260:260::0:0:MeTA1 SMTPS:/nonexistent:/usr/sbin/nologin
meta1q:*:261:261::0:0:MeTA1 QMGR:/nonexistent:/usr/sbin/nologin
meta1c:*:262:262::0:0:MeTA1 SMTPC:/nonexistent:/usr/sbin/nologin
diff --git a/sysutils/spiped/Makefile b/sysutils/spiped/Makefile
index 99308f572a71..b0ebce72e388 100644
--- a/sysutils/spiped/Makefile
+++ b/sysutils/spiped/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= spiped
-PORTVERSION= 1.6.0
-PORTREVISION= 4
+PORTVERSION= 1.6.1
CATEGORIES= sysutils security
MASTER_SITES= http://www.tarsnap.com/spiped/
@@ -35,6 +34,9 @@ USE_RC_SUBR= spiped
OPTIONS_DEFINE= DOCS
+USERS= spiped
+GROUPS= spiped
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/sysutils/spiped/distinfo b/sysutils/spiped/distinfo
index a6d425924407..3f2d18916d8c 100644
--- a/sysutils/spiped/distinfo
+++ b/sysutils/spiped/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495116996
-SHA256 (spiped-1.6.0.tgz) = e6f7f8f912172c3ad55638af8346ae7c4ecaa92aed6d3fb60f2bda4359cba1e4
-SIZE (spiped-1.6.0.tgz) = 94431
+TIMESTAMP = 1586481655
+SHA256 (spiped-1.6.1.tgz) = 8d7089979db79a531a0ecc507b113ac6f2cf5f19305571eff1d3413e0ab33713
+SIZE (spiped-1.6.1.tgz) = 115055
diff --git a/sysutils/spiped/files/spiped.in b/sysutils/spiped/files/spiped.in
index baa3520b5fcf..63b84436fded 100644
--- a/sysutils/spiped/files/spiped.in
+++ b/sysutils/spiped/files/spiped.in
@@ -10,6 +10,8 @@
# to enable this service:
#
# spiped_enable: Set to YES to enable spiped.
+# spiped_uid: User for spiped process (default "spiped").
+# spiped_gid: Group for spiped process (default "spiped").
# spiped_pipes: List of names of pipes to create.
# spiped_pipe_X_mode: "encrypt"/"client" or "decrypt"/"server".
# spiped_pipe_X_source: Source address of pipe X.
@@ -25,6 +27,8 @@ rcvar=spiped_enable
load_rc_config $name
: ${spiped_enable="NO"}
+: ${spiped_uid="spiped"}
+: ${spiped_gid="spiped"}
command=%%PREFIX%%/bin/${name}
start_cmd="${name}_start"
@@ -52,7 +56,8 @@ spiped_start()
echo Invalid value for spiped_pipe_${P}_mode: $MODE
continue
esac
- ${command} -D $MODEFLAG -s $SOURCE -t $TARGET -k $KEY -p $PIDFILE $FLAGS
+ ${command} -D $MODEFLAG -s $SOURCE -t $TARGET -k $KEY \
+ -u ${spiped_uid}:${spiped_gid} -p $PIDFILE $FLAGS
done
}