aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xsynth-dssi/Makefile28
-rw-r--r--audio/xsynth-dssi/distinfo3
-rw-r--r--audio/xsynth-dssi/pkg-descr8
-rw-r--r--audio/xsynth-dssi/pkg-plist8
5 files changed, 48 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index fa33612f18f9..a8b579ed45aa 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -719,6 +719,7 @@
SUBDIR += xmpeg3
SUBDIR += xmradio
SUBDIR += xsidplay
+ SUBDIR += xsynth-dssi
SUBDIR += xtuner
SUBDIR += xvmixer
SUBDIR += xwave
diff --git a/audio/xsynth-dssi/Makefile b/audio/xsynth-dssi/Makefile
new file mode 100644
index 000000000000..44ebc9ce99db
--- /dev/null
+++ b/audio/xsynth-dssi/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xsynth-dssi
+# Date created: 2007-01-20
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xsynth-dssi
+PORTVERSION= 0.9.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dssi
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Classic analog style software synthesizer
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+CFLAGS+= -I${LOCALBASE}/include/dssi
+USE_AUTOTOOLS= libtool:15
+
+.include <bsd.port.mk>
diff --git a/audio/xsynth-dssi/distinfo b/audio/xsynth-dssi/distinfo
new file mode 100644
index 000000000000..8e7398541998
--- /dev/null
+++ b/audio/xsynth-dssi/distinfo
@@ -0,0 +1,3 @@
+MD5 (xsynth-dssi-0.9.0.tar.gz) = ac5cd5d581a18bc393ca31b49fa17c8b
+SHA256 (xsynth-dssi-0.9.0.tar.gz) = 5bfc246f19a044f196660650bcfbab12556c3e9bf2c5cb7de6c0e59ba83af6bf
+SIZE (xsynth-dssi-0.9.0.tar.gz) = 366658
diff --git a/audio/xsynth-dssi/pkg-descr b/audio/xsynth-dssi/pkg-descr
new file mode 100644
index 000000000000..b5fc2d3cce50
--- /dev/null
+++ b/audio/xsynth-dssi/pkg-descr
@@ -0,0 +1,8 @@
+The xsynth-dssi package contains the Xsynth-DSSI plugin, a
+classic-analog (VCOs-VCF-VCA) style software synthesizer with an
+editor GUI. Xsynth-DSSI was written by Sean Bolton, and was based
+on Steve Brooke's Xsynth code, but has since aquired polyphonic
+operation, band-limited oscillators, a better filter mode, and
+velocity-sensitive envelopes.
+
+WWW: http://dssi.sourceforge.net/download.html
diff --git a/audio/xsynth-dssi/pkg-plist b/audio/xsynth-dssi/pkg-plist
new file mode 100644
index 000000000000..1986b27e9356
--- /dev/null
+++ b/audio/xsynth-dssi/pkg-plist
@@ -0,0 +1,8 @@
+lib/dssi/xsynth-dssi/Xsynth_gtk
+lib/dssi/xsynth-dssi.so
+lib/dssi/xsynth-dssi.la
+lib/dssi/xsynth-dssi.a
+%%DATADIR%%/factory_patches.Xsynth
+%%DATADIR%%/version_0.1_patches.Xsynth
+@dirrm %%DATADIR%%
+@dirrm lib/dssi/xsynth-dssi