aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/iftop/Makefile23
-rw-r--r--net-mgmt/iftop/distinfo2
-rw-r--r--net-mgmt/iftop/files/patch-cfgfile.c10
-rw-r--r--net-mgmt/iftop/pkg-plist3
-rw-r--r--net/iftop/Makefile23
-rw-r--r--net/iftop/distinfo2
-rw-r--r--net/iftop/files/patch-cfgfile.c10
-rw-r--r--net/iftop/pkg-plist3
8 files changed, 40 insertions, 36 deletions
diff --git a/net-mgmt/iftop/Makefile b/net-mgmt/iftop/Makefile
index 7f6b5d338e1d..2ee2a852e40b 100644
--- a/net-mgmt/iftop/Makefile
+++ b/net-mgmt/iftop/Makefile
@@ -6,39 +6,34 @@
#
PORTNAME= iftop
-PORTVERSION= 0.14
+PORTVERSION= 0.15
CATEGORIES= net
MASTER_SITES= http://www.ex-parrot.com/~pdw/iftop/download/
MAINTAINER= krion@FreeBSD.org
COMMENT= Network utility for real-time bandwidth usage information
-MAN8= iftop.8
-
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
-DOC_FILES= README \
- COPYING \
- INSTALL \
- TODO
+DOCFILES= README
+
+MAN8= iftop.8
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} \
- -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} \
- ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 \
- ${PREFIX}/man/man8
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
post-install:
.ifndef (NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
-.for doc in ${DOC_FILES}
+.for doc in ${DOCFILES}
@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif
diff --git a/net-mgmt/iftop/distinfo b/net-mgmt/iftop/distinfo
index cedf34b2bc1d..675a75c5a235 100644
--- a/net-mgmt/iftop/distinfo
+++ b/net-mgmt/iftop/distinfo
@@ -1 +1 @@
-MD5 (iftop-0.14.tar.gz) = 6f5197ffbd678565902f4f4d4977512b
+MD5 (iftop-0.15.tar.gz) = 87a0a93b023d73429b0bfc5965a66d2e
diff --git a/net-mgmt/iftop/files/patch-cfgfile.c b/net-mgmt/iftop/files/patch-cfgfile.c
new file mode 100644
index 000000000000..148cd8844a20
--- /dev/null
+++ b/net-mgmt/iftop/files/patch-cfgfile.c
@@ -0,0 +1,10 @@
+--- cfgfile.c.orig Tue Nov 11 22:10:29 2003
++++ cfgfile.c Tue Nov 11 22:10:43 2003
+@@ -8,6 +8,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <errno.h>
++#include <sys/types.h>
+
+ #include "stringmap.h"
+ #include "iftop.h"
diff --git a/net-mgmt/iftop/pkg-plist b/net-mgmt/iftop/pkg-plist
index faa05ecac5b9..4198288675c7 100644
--- a/net-mgmt/iftop/pkg-plist
+++ b/net-mgmt/iftop/pkg-plist
@@ -1,6 +1,3 @@
bin/iftop
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
@dirrm %%PORTDOCS%%%%DOCSDIR%%
diff --git a/net/iftop/Makefile b/net/iftop/Makefile
index 7f6b5d338e1d..2ee2a852e40b 100644
--- a/net/iftop/Makefile
+++ b/net/iftop/Makefile
@@ -6,39 +6,34 @@
#
PORTNAME= iftop
-PORTVERSION= 0.14
+PORTVERSION= 0.15
CATEGORIES= net
MASTER_SITES= http://www.ex-parrot.com/~pdw/iftop/download/
MAINTAINER= krion@FreeBSD.org
COMMENT= Network utility for real-time bandwidth usage information
-MAN8= iftop.8
-
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
-DOC_FILES= README \
- COPYING \
- INSTALL \
- TODO
+DOCFILES= README
+
+MAN8= iftop.8
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} \
- -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} \
- ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 \
- ${PREFIX}/man/man8
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
post-install:
.ifndef (NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
-.for doc in ${DOC_FILES}
+.for doc in ${DOCFILES}
@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif
diff --git a/net/iftop/distinfo b/net/iftop/distinfo
index cedf34b2bc1d..675a75c5a235 100644
--- a/net/iftop/distinfo
+++ b/net/iftop/distinfo
@@ -1 +1 @@
-MD5 (iftop-0.14.tar.gz) = 6f5197ffbd678565902f4f4d4977512b
+MD5 (iftop-0.15.tar.gz) = 87a0a93b023d73429b0bfc5965a66d2e
diff --git a/net/iftop/files/patch-cfgfile.c b/net/iftop/files/patch-cfgfile.c
new file mode 100644
index 000000000000..148cd8844a20
--- /dev/null
+++ b/net/iftop/files/patch-cfgfile.c
@@ -0,0 +1,10 @@
+--- cfgfile.c.orig Tue Nov 11 22:10:29 2003
++++ cfgfile.c Tue Nov 11 22:10:43 2003
+@@ -8,6 +8,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <errno.h>
++#include <sys/types.h>
+
+ #include "stringmap.h"
+ #include "iftop.h"
diff --git a/net/iftop/pkg-plist b/net/iftop/pkg-plist
index faa05ecac5b9..4198288675c7 100644
--- a/net/iftop/pkg-plist
+++ b/net/iftop/pkg-plist
@@ -1,6 +1,3 @@
bin/iftop
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
@dirrm %%PORTDOCS%%%%DOCSDIR%%