aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/gnu-cobol/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/gnu-cobol/Makefile b/lang/gnu-cobol/Makefile
index 3aac3257f0fe..1f46f09b897c 100644
--- a/lang/gnu-cobol/Makefile
+++ b/lang/gnu-cobol/Makefile
@@ -13,7 +13,7 @@ COMMENT= Open-source COBOL compiler
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
USE_BDB= yes
-USES= gmake libtool
+USES= gmake libtool ncurses
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -30,6 +30,7 @@ CONFIGURE_ENABLE=nls
post-patch:
@${REINPLACE_CMD} -e 's|__gmp_randinit|__gmpz_init|g ; \
s|db-4.[0-9]|${BDB_LIB_NAME}|g ; \
+ s|-lcurses|-lncurses|g ; \
s|-R$$found_dir|-Wl,-rpath,$$found_dir|g' ${WRKSRC}/configure
.include <bsd.port.mk>