aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/innoextract/Makefile6
-rw-r--r--audio/mpdas/Makefile2
-rw-r--r--biology/stacks/Makefile2
-rw-r--r--databases/p5-DBD-cego/Makefile3
-rw-r--r--databases/postgresql-libpqxx/Makefile2
-rw-r--r--devel/eblob/Makefile3
-rw-r--r--devel/gecode/Makefile8
-rw-r--r--devel/libftdi1/Makefile6
-rw-r--r--devel/libvirt/Makefile2
-rw-r--r--devel/xsd/Makefile2
-rw-r--r--editors/medit/Makefile2
-rw-r--r--editors/texworks/Makefile2
-rw-r--r--graphics/ayam/Makefile2
-rw-r--r--graphics/diffpdf/Makefile2
-rw-r--r--graphics/epdfview/Makefile2
-rw-r--r--graphics/py-poppler-qt4/Makefile2
-rw-r--r--graphics/qcomicbook/Makefile2
-rw-r--r--graphics/vips/Makefile2
-rw-r--r--mail/gnubiff/Makefile6
-rw-r--r--net/frr4/Makefile2
-rw-r--r--net/ostinato/Makefile2
-rw-r--r--news/nget/Makefile2
-rw-r--r--print/qpdfview/Makefile2
-rw-r--r--science/tfel/Makefile2
-rw-r--r--security/md5deep/Makefile2
-rw-r--r--sysutils/tmux-mem-cpu-load/Makefile5
-rw-r--r--textproc/goldendict/Makefile2
-rw-r--r--www/varnish5/Makefile4
28 files changed, 39 insertions, 42 deletions
diff --git a/archivers/innoextract/Makefile b/archivers/innoextract/Makefile
index d153008d2eef..dd22a9f7dabe 100644
--- a/archivers/innoextract/Makefile
+++ b/archivers/innoextract/Makefile
@@ -12,16 +12,16 @@ COMMENT= Program to extract Inno Setup files
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_sparc64= Does not build: undefined reference to std::ctype<char>::_M_widen_init()
+
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
libboost_filesystem.so:devel/boost-libs \
libboost_system.so:devel/boost-libs \
libboost_program_options.so:devel/boost-libs
-USES= cmake iconv
+USES= cmake compiler:c++11-lang iconv
PLIST_FILES= bin/innoextract \
man/man1/innoextract.1.gz
-BROKEN_sparc64= Does not build: undefined reference to std::ctype<char>::_M_widen_init()
-
.include <bsd.port.mk>
diff --git a/audio/mpdas/Makefile b/audio/mpdas/Makefile
index f2bfbe547348..fdccac93aa7f 100644
--- a/audio/mpdas/Makefile
+++ b/audio/mpdas/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcurl.so:ftp/curl \
libmpdclient.so:audio/libmpdclient
-USES= pkgconfig
+USES= compiler:c++11-lang pkgconfig
USE_RC_SUBR= mpdas
diff --git a/biology/stacks/Makefile b/biology/stacks/Makefile
index a7582268a71d..c032bca677f9 100644
--- a/biology/stacks/Makefile
+++ b/biology/stacks/Makefile
@@ -11,7 +11,7 @@ COMMENT= Software pipeline for building loci from short-read sequences
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake python shebangfix
+USES= compiler:c++11-lang gmake python shebangfix
SHEBANG_FILES= scripts/*.pl scripts/*.py
GNU_CONFIGURE= yes
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
index 3d5c2ed86bda..b6cc6714ffb6 100644
--- a/databases/p5-DBD-cego/Makefile
+++ b/databases/p5-DBD-cego/Makefile
@@ -15,9 +15,10 @@ BUILD_DEPENDS= p5-DBI>=1.631:databases/p5-DBI
RUN_DEPENDS= p5-DBI>=1.631:databases/p5-DBI
LIB_DEPENDS= libcego.so:databases/cego
-USES= gmake perl5
+USES= compiler gmake perl5
USE_PERL5= configure
CC:= ${CXX}
+COMPILER_TYPE= clang
CONFIGURE_ARGS+= --prefix=${PREFIX}
post-install:
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 0991759b9cfe..524a20033ede 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD3CLAUSE
CONFLICTS= postgresql-libpqxx-[1-5].* postgresql-libpqxx3-3.* \
postgresql-libpqxx4-4.*
-USES= gmake libtool pathfix pgsql python:2.7,build shebangfix
+USES= compiler:c++11-lang gmake libtool pathfix pgsql python:2.7,build shebangfix
USE_GITHUB= yes
GH_ACCOUNT= jtv
GNU_CONFIGURE= yes
diff --git a/devel/eblob/Makefile b/devel/eblob/Makefile
index 5a4dbce52725..ae81e9896759 100644
--- a/devel/eblob/Makefile
+++ b/devel/eblob/Makefile
@@ -13,11 +13,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
GH_TAGNAME= 0a75b89
-
-USES= cmake
USE_LDCONFIG= yes
OPTIONS_DEFINE= ASSERT PYTHON SNAPPY EXAMPLES TESTS
diff --git a/devel/gecode/Makefile b/devel/gecode/Makefile
index 16f7a73244a3..904cf7077739 100644
--- a/devel/gecode/Makefile
+++ b/devel/gecode/Makefile
@@ -13,13 +13,13 @@ COMMENT= Generic Constraint Development Environment
LICENSE= BSL MIT
LICENSE_COMB= multi
-LIB_DEPENDS= libmpfr.so:math/mpfr \
- libgmp.so:math/gmp
-
NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64
NOT_FOR_ARCHS_REASON= needs code written to specify rounding control mechanism in Boost.Numeric.Interval
-USES= bison gmake perl5
+LIB_DEPENDS= libmpfr.so:math/mpfr \
+ libgmp.so:math/gmp
+
+USES= bison compiler:c++11-lang gmake perl5
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static \
diff --git a/devel/libftdi1/Makefile b/devel/libftdi1/Makefile
index d0ca980dff48..a27fbed77805 100644
--- a/devel/libftdi1/Makefile
+++ b/devel/libftdi1/Makefile
@@ -11,6 +11,8 @@ COMMENT= Library (using libusb) to talk to FTDI chips
LICENSE= GPLv2
+BROKEN_sparc64= Does not build: fails to link
+
LIB_DEPENDS= libconfuse.so:devel/libconfuse
OPTIONS_DEFINE= PYTHON BOOST DOCS EXAMPLES
@@ -20,9 +22,7 @@ OPTIONS_SUB= yes
BOOST_DESC= Build with boost
PYTHON_DESC= Build Python bindings
-BROKEN_sparc64= Does not build: fails to link
-
-USES= cmake gettext-runtime pkgconfig tar:bzip2
+USES= cmake compiler:c++11-lang gettext-runtime pkgconfig tar:bzip2
USE_LDCONFIG= yes
PORTDOCS= COPYING.LIB ChangeLog README
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index ace79b67adfc..12d7100d69ee 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -97,7 +97,7 @@ PORTSCOUT= limit:\d+\.\d+\.\d+$$
LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
-USES= charsetfix cpe gettext-runtime gmake libtool pathfix \
+USES= charsetfix compiler:c++0x cpe gettext-runtime gmake libtool pathfix \
perl5 python:build pkgconfig shebangfix tar:xz
USE_RC_SUBR= libvirtd virtlogd
CPE_VENDOR= redhat
diff --git a/devel/xsd/Makefile b/devel/xsd/Makefile
index a159b57f44cd..ea8b05b1f906 100644
--- a/devel/xsd/Makefile
+++ b/devel/xsd/Makefile
@@ -33,7 +33,7 @@ MAKE_ARGS= EXTERNAL_LIBCUTL=y \
install_prefix=${STAGEDIR}${PREFIX} \
install_man_dir=${STAGEDIR}${MANPREFIX}/man \
verbose=1
-USES= gmake tar:bzip2
+USES= compiler:c++11-lang gmake tar:bzip2
post-patch:
# Use devel/build instead of the port's bundled copy.
diff --git a/editors/medit/Makefile b/editors/medit/Makefile
index 886cb8c4831a..e6515af774ff 100644
--- a/editors/medit/Makefile
+++ b/editors/medit/Makefile
@@ -13,7 +13,7 @@ COMMENT= Programming and around-programming text editor
LICENSE= LGPL21
-USES= gmake localbase pkgconfig tar:bzip2
+USES= compiler:c++11-lang gmake localbase pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= gtk20
INSTALLS_ICONS= yes
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 551ab4f9a2c3..7881c45525ea 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -18,7 +18,7 @@ BROKEN_armv7= fails to install: PDFDocument.cpp:1836:39: cannot initialize a pa
BUILD_DEPENDS= hunspell:textproc/hunspell
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-USES= pkgconfig qmake
+USES= compiler:c++11-lang pkgconfig qmake
USE_GITHUB= yes
GH_ACCOUNT= TeXworks
USE_QT4= gui corelib rcc_build moc_build uic_build \
diff --git a/graphics/ayam/Makefile b/graphics/ayam/Makefile
index 1acdeeb4fdee..16943002dee1 100644
--- a/graphics/ayam/Makefile
+++ b/graphics/ayam/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
WRKSRC= ${WRKDIR}/${PORTNAME}/src
-USES= gmake tk
+USES= compiler:c++11-lang gmake tk
USE_XORG= x11 xext xmu
USE_GL= glu
MAKE_ENV= TCL_INCLUDEDIR="${TCL_INCLUDEDIR}" \
diff --git a/graphics/diffpdf/Makefile b/graphics/diffpdf/Makefile
index f24731f9c374..f19052e0c161 100644
--- a/graphics/diffpdf/Makefile
+++ b/graphics/diffpdf/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2+
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-USES= qmake
+USES= compiler:c++11-lang qmake
USE_QT4= qmake_build moc_build rcc_build uic_build linguist_build
PLIST_FILES= bin/diffpdf
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
index 6f25940281d9..7996266c212f 100644
--- a/graphics/epdfview/Makefile
+++ b/graphics/epdfview/Makefile
@@ -18,9 +18,9 @@ LICENSE= GPLv2
BUILD_DEPENDS= cppunit-config:devel/cppunit
LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
+USES= compiler:c++11-lang desktop-file-utils iconv gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USES= desktop-file-utils iconv gmake pkgconfig tar:bzip2
USE_GNOME= gtk20 intlhack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/py-poppler-qt4/Makefile b/graphics/py-poppler-qt4/Makefile
index 0f8bb2ae9d22..387aa4b194dd 100644
--- a/graphics/py-poppler-qt4/Makefile
+++ b/graphics/py-poppler-qt4/Makefile
@@ -16,7 +16,7 @@ LICENSE_COMB= dual
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-USES= pkgconfig pyqt:4 python
+USES= compiler:c++11-lang pkgconfig pyqt:4 python
USE_PYQT= gui xml sip_build
USE_PYTHON= distutils autoplist
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index 21f9784c295d..ecac4b6fa55d 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-USES= cmake:outsource pkgconfig
+USES= cmake:outsource compiler:c++11-lang pkgconfig
USE_QT4= corelib gui linguisttools_build moc_build qmake_build rcc_build \
uic_build xml
diff --git a/graphics/vips/Makefile b/graphics/vips/Makefile
index 5ba5286ba7fe..5b877ed989d8 100644
--- a/graphics/vips/Makefile
+++ b/graphics/vips/Makefile
@@ -34,7 +34,7 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libhdf5.so:science/hdf5 \
libexpat.so:textproc/expat2
-USES= cpe gettext gmake jpeg libtool pathfix pkgconfig python:2.7 shebangfix
+USES= compiler:c++11-lang cpe gettext gmake jpeg libtool pathfix pkgconfig python:2.7 shebangfix
SHEBANG_FILES= tools/vips-${PORTVERSION:R} tools/vipsprofile
USE_GNOME= cairo gdkpixbuf2 glib20 libgsf librsvg2 libxml2 pango
GNU_CONFIGURE= yes
diff --git a/mail/gnubiff/Makefile b/mail/gnubiff/Makefile
index 341cc0176195..81cf60f2308e 100644
--- a/mail/gnubiff/Makefile
+++ b/mail/gnubiff/Makefile
@@ -10,12 +10,12 @@ MASTER_SITES= SF
MAINTAINER= tdb@FreeBSD.org
COMMENT= Mail notification program for Gnome
-OPTIONS_DEFINE= NLS
-
LIB_DEPENDS= libpopt.so:devel/popt
+OPTIONS_DEFINE= NLS
+
+USES= compiler:c++11-lang cpe fam gmake pathfix pkgconfig
USE_GNOME= intlhack libglade2 esound
-USES= cpe fam gmake pathfix pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lX11
diff --git a/net/frr4/Makefile b/net/frr4/Makefile
index af28308f5013..6e937e62f5a4 100644
--- a/net/frr4/Makefile
+++ b/net/frr4/Makefile
@@ -18,9 +18,9 @@ LIB_DEPENDS= libjson-c.so:devel/json-c
CONFLICTS= openbgpd openospfd zebra quagga frr3
+USES= autoreconf bison compiler:c++11-lang gmake pkgconfig libtool makeinfo readline
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= autoreconf bison gmake pkgconfig libtool makeinfo python:2.7,build readline
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/net/ostinato/Makefile b/net/ostinato/Makefile
index cc8f45b21054..2f9cea76bd2b 100644
--- a/net/ostinato/Makefile
+++ b/net/ostinato/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-USES= qmake
+USES= compiler:c++11-lang qmake
USE_QT4= corelib gui moc_build rcc_build uic_build network script \
xml
diff --git a/news/nget/Makefile b/news/nget/Makefile
index fc58cc2b1f81..818b25a66f7e 100644
--- a/news/nget/Makefile
+++ b/news/nget/Makefile
@@ -14,7 +14,7 @@ COMMENT= Auto-resuming command line nntp file grabber
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake
+USES= compiler:c++11-lang gmake
GNU_CONFIGURE= yes
# Skip check if the C++ compiler supports exceptions. We know both
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index c4a7d7f87b9d..dc5c8369c2af 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -13,7 +13,7 @@ COMMENT= Tabbed DjVu/PDF/PS document viewer
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= desktop-file-utils pkgconfig qmake
+USES= compiler:c++11-lang desktop-file-utils pkgconfig qmake
USE_LDCONFIG= yes
QMAKE_SOURCE_PATH= ${PORTNAME}.pro
diff --git a/science/tfel/Makefile b/science/tfel/Makefile
index f30e554e2a0a..cd466cd3c66d 100644
--- a/science/tfel/Makefile
+++ b/science/tfel/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= gnuplot:math/gnuplot
RUN_DEPENDS= gnuplot:math/gnuplot
-USES= cmake tar:bzip2
+USES= cmake compiler:c++0x tar:bzip2
OPTIONS_DEFINE= DOCS PYTHON
OPTIONS_DEFAULT= PYTHON
diff --git a/security/md5deep/Makefile b/security/md5deep/Makefile
index a225acab2ca1..3d094da06459 100644
--- a/security/md5deep/Makefile
+++ b/security/md5deep/Makefile
@@ -15,8 +15,8 @@ GH_ACCOUNT= jessek
GH_PROJECT= hashdeep
GH_TAGNAME= cd2ed74
+USES= autoreconf compiler:c++11-lang gmake
USE_GITHUB= yes
-USES= autoreconf gmake
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/sysutils/tmux-mem-cpu-load/Makefile b/sysutils/tmux-mem-cpu-load/Makefile
index a9dc85373fe2..dce35ae54317 100644
--- a/sysutils/tmux-mem-cpu-load/Makefile
+++ b/sysutils/tmux-mem-cpu-load/Makefile
@@ -13,13 +13,10 @@ LICENSE= APACHE20
RUN_DEPENDS= tmux:sysutils/tmux
-BROKEN_powerpc64= fails to compile: Compiler GNU 4.2.1 has no C++11 support
-
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= thewtex
-USES= cmake
-
PLIST_FILES= bin/tmux-mem-cpu-load
.include <bsd.port.mk>
diff --git a/textproc/goldendict/Makefile b/textproc/goldendict/Makefile
index 29387d8e957e..5cede86ac6ca 100644
--- a/textproc/goldendict/Makefile
+++ b/textproc/goldendict/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
libvorbis.so:audio/libvorbis
NO_WRKSUBDIR= yes
-USES= dos2unix iconv:wchar_t pkgconfig qmake tar:bzip2
+USES= compiler:c++11-lang dos2unix iconv:wchar_t pkgconfig qmake tar:bzip2
DOS2UNIX_FILES= processwrapper.cc
USE_XORG= xtst
USE_QT4= corelib gui webkit phonon \
diff --git a/www/varnish5/Makefile b/www/varnish5/Makefile
index 6bc7ab8dba56..944c393dc9cb 100644
--- a/www/varnish5/Makefile
+++ b/www/varnish5/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= libpcre.so:devel/pcre
CONFLICTS= varnish-2.* varnish-3.* varnish4-4.*
-USES= autoreconf cpe gmake libedit libtool ncurses pathfix \
- pkgconfig python:2.7,build readline shebangfix
+USES= autoreconf compiler:c++11-lang cpe gmake libedit libtool \
+ ncurses pathfix pkgconfig python:2.7,build readline shebangfix
SHEBANG_FILES= lib/libvcc/*.py
CPE_VENDOR= varnish-cache
CFLAGS+= -I${LOCALBASE}/include