aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/dams/Makefile25
-rw-r--r--japanese/dams/distinfo3
-rw-r--r--japanese/dams/files/patch-Makefile.in16
-rw-r--r--japanese/dams/files/patch-lib_openfile.cpp11
-rw-r--r--japanese/dams/pkg-descr5
-rw-r--r--japanese/dams/pkg-plist7
7 files changed, 68 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 492d67b68e5c..50772df5cf9b 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -34,6 +34,7 @@
SUBDIR += cp5022x-el
SUBDIR += csrd
SUBDIR += ctags
+ SUBDIR += dams
SUBDIR += dbskkd-cdb
SUBDIR += ddskk
SUBDIR += devil-fpw
diff --git a/japanese/dams/Makefile b/japanese/dams/Makefile
new file mode 100644
index 000000000000..0cd02be2b85e
--- /dev/null
+++ b/japanese/dams/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= dams
+PORTVERSION= 4.3.4
+CATEGORIES= japanese
+MASTER_SITES= http://newspat.csis.u-tokyo.ac.jp/download/
+
+MAINTAINER= bokutin@bokut.in
+COMMENT= Geocoder that converts address strings into latitude and longitude
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake libtool tar:tgz
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+MAKE_JOBS_UNSAFE= yes
+ALL_TARGET= all dic
+INSTALL_TARGET= install install-dic install-strip
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/dams ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/japanese/dams/distinfo b/japanese/dams/distinfo
new file mode 100644
index 000000000000..b555468a9869
--- /dev/null
+++ b/japanese/dams/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578031274
+SHA256 (dams-4.3.4.tgz) = 680d76eeba01d7cc93a6acb356173ba7ea2a842f59961bfeecf3777fbebc83f7
+SIZE (dams-4.3.4.tgz) = 66115848
diff --git a/japanese/dams/files/patch-Makefile.in b/japanese/dams/files/patch-Makefile.in
new file mode 100644
index 000000000000..03b1ce29f741
--- /dev/null
+++ b/japanese/dams/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig 2015-12-24 23:13:21 UTC
++++ Makefile.in
+@@ -731,10 +731,10 @@ test: $(DIC) $(DAMS)
+ dic: $(DIC)
+
+ install-dic:
+- @if ! [ -d $(libdir)/dams ]; \
+- then mkdir -p $(libdir)/dams; \
++ @if ! [ -d $(DESTDIR)$(libdir)/dams ]; \
++ then mkdir -p $(DESTDIR)$(libdir)/dams; \
+ fi
+- $(install_sh_DATA) $(DIC) $(libdir)/dams
++ $(install_sh_DATA) $(DIC) $(DESTDIR)$(libdir)/dams
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/japanese/dams/files/patch-lib_openfile.cpp b/japanese/dams/files/patch-lib_openfile.cpp
new file mode 100644
index 000000000000..4a84f9cdd2b3
--- /dev/null
+++ b/japanese/dams/files/patch-lib_openfile.cpp
@@ -0,0 +1,11 @@
+--- lib/openfile.cpp.orig 2015-12-25 14:22:43 UTC
++++ lib/openfile.cpp
+@@ -53,7 +53,7 @@ int openfile(const char* fname) {
+ if (!pbase) {
+ pbase = mmap((caddr_t)0, st.st_size, PROT_READ, MAP_PRIVATE, fildes, 0);
+ onmemory = 0;
+- if (pbase < 0) {
++ if (pbase == MAP_FAILED) {
+ /* mmap failed */
+ fprintf(stderr, "ERR: failed to execute mmap.\n");
+ return -1;
diff --git a/japanese/dams/pkg-descr b/japanese/dams/pkg-descr
new file mode 100644
index 000000000000..0bc9cf1e31e2
--- /dev/null
+++ b/japanese/dams/pkg-descr
@@ -0,0 +1,5 @@
+Geocoder DAMS (Distributed Address Matching System) is software
+that provides a "geocoding" function that converts address strings
+into latitude and longitude.
+
+WWW: http://newspat.csis.u-tokyo.ac.jp/geocode/
diff --git a/japanese/dams/pkg-plist b/japanese/dams/pkg-plist
new file mode 100644
index 000000000000..a56acd6dcd4f
--- /dev/null
+++ b/japanese/dams/pkg-plist
@@ -0,0 +1,7 @@
+bin/dams
+include/dams.h
+lib/dams/dams.dat
+lib/dams/dams.try
+lib/libdams-4.3.4.so
+lib/libdams.a
+lib/libdams.so