aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/gtkglarea2/Makefile13
-rw-r--r--x11-toolkits/gtkglarea2/files/patch-Makefile.in11
2 files changed, 19 insertions, 5 deletions
diff --git a/x11-toolkits/gtkglarea2/Makefile b/x11-toolkits/gtkglarea2/Makefile
index 65fb00973400..7cbd791fd482 100644
--- a/x11-toolkits/gtkglarea2/Makefile
+++ b/x11-toolkits/gtkglarea2/Makefile
@@ -1,6 +1,5 @@
# Created by: Marc Recht <marc@informatik.uni-bremen.de>
# $FreeBSD$
-# $MCom: ports/x11-toolkits/gtkglarea2/Makefile,v 1.2 2006/09/10 00:51:17 mezz Exp $
PORTNAME= gtkglarea
PORTVERSION= 2.0.1
@@ -10,13 +9,17 @@ MASTER_SITES= GNOME
DISTNAME= gtkglarea-${PORTVERSION}
DIST_SUBDIR= gnome2
-MAINTAINER= gnome@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL widget for the GTK+2 GUI toolkit
-USES= compiler:c++11-lang libtool:keepla pathfix pkgconfig tar:bzip2
-USE_GNOME= gtk20
-USE_GL= yes
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+USES= compiler:c++11-lang gl gnome libtool:keepla pathfix pkgconfig tar:bzip2
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_GL= gl glu
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lib-GL
INSTALL_TARGET= install-strip
diff --git a/x11-toolkits/gtkglarea2/files/patch-Makefile.in b/x11-toolkits/gtkglarea2/files/patch-Makefile.in
new file mode 100644
index 000000000000..db58b342e813
--- /dev/null
+++ b/x11-toolkits/gtkglarea2/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2019-03-23 10:53:10 UTC
++++ Makefile.in
+@@ -208,7 +208,7 @@ top_srcdir = @top_srcdir@
+ # use the ACLOCAL_FLAGS env var when rerunning aclocal
+ ACLOCAL_FLAGS =
+ ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
+-SUBDIRS = gtkgl examples docs # build
++SUBDIRS = gtkgl docs # build
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = gtkgl-2.0.pc
+ EXTRA_DIST = \