aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs1
-rw-r--r--irc/ratbox-services/Makefile4
-rw-r--r--irc/ratbox-services/files/pkg-install.in83
3 files changed, 5 insertions, 83 deletions
diff --git a/GIDs b/GIDs
index 6cbe44e02457..04185eef56d1 100644
--- a/GIDs
+++ b/GIDs
@@ -13,6 +13,7 @@ dialer:*:68:
network:*:69:
pgsql:*:70:
ircd:*:72:
+ircservices:*:73:
simscan:*:74:
hybserv:*:76:
audit:*:77:
diff --git a/irc/ratbox-services/Makefile b/irc/ratbox-services/Makefile
index 223417abe167..455ed94a4a92 100644
--- a/irc/ratbox-services/Makefile
+++ b/irc/ratbox-services/Makefile
@@ -19,6 +19,9 @@ COMMENT= A highly configurable services package for use with ircd-ratbox
USE_RC_SUBR= ratbox-services.sh
+USERS= ircservices
+GROUPS= ${USERS}
+
LOGDIR?= /var/log
RUNDIR?= /var/run
DBDIR?= /var/db/${PORTNAME}
@@ -168,7 +171,6 @@ post-patch:
${WRKSRC}/tools/dbupgrade.pl
pre-su-install:
- @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
${MKDIR} ${DATADIR}/help
post-install:
diff --git a/irc/ratbox-services/files/pkg-install.in b/irc/ratbox-services/files/pkg-install.in
index 7003b0b790fa..093437dd7981 100644
--- a/irc/ratbox-services/files/pkg-install.in
+++ b/irc/ratbox-services/files/pkg-install.in
@@ -3,92 +3,11 @@
# Adapted from irc/ircd-hybrid's script
#
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
#-----------------------------------------------------------------------
if [ "x$2" = "xPRE-INSTALL" ]; then
#-----------------------------------------------------------------------
-if which -s pw ; then
- :
-else
- cat <<EOF
-Your system does not include the "pw" utility. You should upgrade
-to a newer version of FreeBSD. Without "pw" this script will not
-run.
-EOF
- exit 1
-fi
-
-echo ""
-if pw groupshow ircservices 2> /dev/null ; then
- echo "You already have a group \"ircservices\", so I will use it."
-else
- if pw groupshow 73 2> /dev/null ; then
- echo "You already have a gid \"73\". Please create a user \"ircservices\""
- echo "with a default group of \"ircservices\"."
- exit 1
- fi
- echo "You need a group \"ircservices\"."
- if which -s pw && yesno "Would you like me to create it" y; then
- pw groupadd ircservices -g 73 || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- if ! pw usershow ircservices 2> /dev/null ; then
- echo "While you're at it, please create a user \"ircservices\""
- echo 'too, with a default group of "ircservices".'
- fi
- exit 1
- fi
-fi
-
-if pw usershow ircservices 2> /dev/null ; then
- echo "You already have a user \"ircservices\", so I will use it."
-else
- if pw usershow 73 2> /dev/null ; then
- echo "You already have a uid \"73\". Please create a user \"irc
-d\""
- echo "with a default group of \"ircservices\"."
- exit 1
- fi
- echo "You need a user \"ircservices\"."
- if which -s pw && yesno "Would you like me to create it" y; then
- pw useradd ircservices -g ircservices -u 73 -h - -d /nonexistent \
- -s /nonexistent -c "IRC services" || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
-fi
+# ${DO_NADA}
#-----------------------------------------------------------------------
elif [ "x$2" = "xPOST-INSTALL" ]; then