aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pyfixbuf/Makefile24
-rw-r--r--net/py-pyfixbuf/distinfo3
-rw-r--r--net/py-pyfixbuf/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aeacd802d7c5..a3b8ed05c000 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1075,6 +1075,7 @@
SUBDIR += py-port-for
SUBDIR += py-portend
SUBDIR += py-pyenet
+ SUBDIR += py-pyfixbuf
SUBDIR += py-pygeoip
SUBDIR += py-pyicap
SUBDIR += py-pynamecheap
diff --git a/net/py-pyfixbuf/Makefile b/net/py-pyfixbuf/Makefile
new file mode 100644
index 000000000000..6f14e0f4aca6
--- /dev/null
+++ b/net/py-pyfixbuf/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= pyfixbuf
+PORTVERSION= 0.8.1
+CATEGORIES= net python
+MASTER_SITES= https://tools.netsa.cert.org/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Python API for libfixbuf
+
+LICENSE= GPLR LGPL21
+LICENSE_COMB= multi
+LICENSE_NAME_GPLR= Government Purpose License Rights
+LICENSE_FILE_GPLR= ${WRKSRC}/LICENSE-OPENSOURCE.txt
+LICENSE_PERMS_GPLR= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${PY_IPADDRESS}
+LIB_DEPENDS= libfixbuf.so:net/libfixbuf
+
+USES= pkgconfig python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/net/py-pyfixbuf/distinfo b/net/py-pyfixbuf/distinfo
new file mode 100644
index 000000000000..7b5c8937b80b
--- /dev/null
+++ b/net/py-pyfixbuf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579611260
+SHA256 (pyfixbuf-0.8.1.tar.gz) = 57c7606a879bc7010c3e1a4be41200bbf80fb4fe236d779dd4f34d9f3b8d3d12
+SIZE (pyfixbuf-0.8.1.tar.gz) = 695029
diff --git a/net/py-pyfixbuf/pkg-descr b/net/py-pyfixbuf/pkg-descr
new file mode 100644
index 000000000000..8d658ea9dafc
--- /dev/null
+++ b/net/py-pyfixbuf/pkg-descr
@@ -0,0 +1,4 @@
+pyfixbuf is a Python API for libfixbuf, an implementation of the IPFIX protocol
+used for building collecting and exporting processes.
+
+WWW: https://tools.netsa.cert.org/pyfixbuf/