aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/jggtrans/Makefile55
-rw-r--r--net-im/jggtrans/distinfo3
-rw-r--r--net-im/jggtrans/files/jggtrans.sh.in25
-rw-r--r--net-im/jggtrans/pkg-descr7
-rw-r--r--net-im/jggtrans/pkg-message8
-rw-r--r--net-im/jggtrans/pkg-plist8
7 files changed, 107 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 55f076e053af..5920c03b94a3 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -58,6 +58,7 @@
SUBDIR += jabber-yahoo
SUBDIR += jabber-users-agent
SUBDIR += jarl
+ SUBDIR += jggtrans
SUBDIR += jit
SUBDIR += jwchat
SUBDIR += kf
diff --git a/net-im/jggtrans/Makefile b/net-im/jggtrans/Makefile
new file mode 100644
index 000000000000..4788b5b46b2f
--- /dev/null
+++ b/net-im/jggtrans/Makefile
@@ -0,0 +1,55 @@
+# Ports collection makefile for: jggtrans
+# Date created: 13 September 2006
+# Whom: Bartek Rutkowski <r@robakdesign.com>
+#
+# $FreeBSD$
+
+PORTNAME= jggtrans
+PORTVERSION= 2.2.2
+CATEGORIES= net-im polish
+MASTER_SITES= http://jggtrans.jajcus.net/downloads/ \
+ http://freebsd.e.pl/distfiles/
+
+MAINTAINER= r@robakdesign.com
+COMMENT= Jabberd XMPP to GG instant messaging service gateway
+
+LIB_DEPENDS= idn.16:${PORTSDIR}/dns/libidn \
+ expat.6:${PORTSDIR}/textproc/expat2
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+USE_GNOME= glib20 pkgconfig
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+USE_RC_SUBR= jggtrans.sh
+
+USE_LDCONFIG= yes
+
+OPTIONS= NODEBUG "Turn off debugging code" off \
+ EJABBERD "Use transport with ejabberd" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NODEBUG)
+CONFIGURE_ARGS+= --disable-debug
+.endif
+
+.if defined(WITH_EJABBERD)
+JABBER_USER?= ejabberd
+SUB_LIST+= JABBER_REQUIRE=ejabberd
+.else
+JABBER_USER?= jabber
+SUB_LIST+= JABBER_REQUIRE=jabberd
+.endif
+
+SUB_LIST+= JABBER_USER=${JABBER_USER}
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/jggtrans.xml ]; then ${CP} -p ${WRKSRC}/jggtrans.xml ${PREFIX}/etc/jggtrans.xml.sample ; fi
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-im/jggtrans/distinfo b/net-im/jggtrans/distinfo
new file mode 100644
index 000000000000..ddd5472ea45c
--- /dev/null
+++ b/net-im/jggtrans/distinfo
@@ -0,0 +1,3 @@
+MD5 (jggtrans-2.2.2.tar.gz) = 70bbec4e9c438cda6b7379ccfc63492f
+SHA256 (jggtrans-2.2.2.tar.gz) = 00a4956ec2aaf22eacb28b8af2ab0742caa3deffbd895ce86bcd76b6f604a007
+SIZE (jggtrans-2.2.2.tar.gz) = 1176462
diff --git a/net-im/jggtrans/files/jggtrans.sh.in b/net-im/jggtrans/files/jggtrans.sh.in
new file mode 100644
index 000000000000..9339edbe9467
--- /dev/null
+++ b/net-im/jggtrans/files/jggtrans.sh.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# PROVIDE: jggtrans
+# REQUIRE: DAEMON %%JABBER_USER%%
+# BEFORE: LOGIN
+# KEYWORD: FreeBSD shutdown
+
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+# SET THEM IN THE /etc/rc.conf
+
+. %%RC_SUBR%%
+
+name="jggtrans"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${jggtrans_enable="NO"}
+: ${jggtrans_program="%%PREFIX%%/sbin/jggtrans"}
+: ${jggtrans_flags="-u %%JABBER_USER%% -g %%JABBER_USER%%"}
+: ${jggtrans_pidfile="/var/jabberd/pid/jggtrans.pid"}
+
+start_cmd="echo \"Starting ${name}.\"; /usr/bin/nice -5 ${jggtrans_program} ${jggtrans_flags}"
+
+run_rc_command "$1"
diff --git a/net-im/jggtrans/pkg-descr b/net-im/jggtrans/pkg-descr
new file mode 100644
index 000000000000..5f0df7abc4e3
--- /dev/null
+++ b/net-im/jggtrans/pkg-descr
@@ -0,0 +1,7 @@
+jGGtrans (GG Transport), is external component for XMPP/Jabber
+server providing gateway to GaduGadu instant messaging services.
+jGGtrans is known to work well together with ejabberd, jabberd
+1.4 and jabberd 2, but most other Jabber server implementations
+should work too.
+
+WWW: http://jggtrans.jajcus.net/
diff --git a/net-im/jggtrans/pkg-message b/net-im/jggtrans/pkg-message
new file mode 100644
index 000000000000..73b103575bdd
--- /dev/null
+++ b/net-im/jggtrans/pkg-message
@@ -0,0 +1,8 @@
+******************************************************************************
+
+Remember to edit jggtrans.xml to suit your needs.
+Also, keep in mind, that jggtrans should be always started with
+the same uid and gid as your Jabberd daemon, and never should
+be launched before it.
+
+******************************************************************************
diff --git a/net-im/jggtrans/pkg-plist b/net-im/jggtrans/pkg-plist
new file mode 100644
index 000000000000..9e0c01d3863f
--- /dev/null
+++ b/net-im/jggtrans/pkg-plist
@@ -0,0 +1,8 @@
+sbin/jggtrans
+share/locale/nl/LC_MESSAGES/jggtrans.mo
+share/locale/pl/LC_MESSAGES/jggtrans.mo
+@unexec if cmp -s %D/etc/jggtrans.xml.sample %D/etc/jggtrans.xml; then rm -f %D/etc/jggtrans.xml; fi
+etc/jggtrans.xml.sample
+@exec if [ ! -f %D/etc/jggtrans.xml ] ; then cp -p %D/%F %B/jggtrans.xml; fi
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl