aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/py-attic/Makefile3
-rw-r--r--archivers/py-borgbackup/Makefile3
-rw-r--r--audio/lollypop/Makefile3
-rw-r--r--comms/wsjt/Makefile3
-rw-r--r--comms/wspr/Makefile3
-rw-r--r--mail/rss2email3/Makefile3
-rw-r--r--math/convertall/Makefile3
-rw-r--r--math/rpcalc/Makefile3
-rw-r--r--multimedia/mps-youtube/Makefile3
-rw-r--r--net-im/poezio/Makefile3
-rw-r--r--net/tiny-network-utilities/Makefile3
-rw-r--r--ports-mgmt/py-pytoport/Makefile3
-rw-r--r--security/morphis/Makefile3
13 files changed, 26 insertions, 13 deletions
diff --git a/archivers/py-attic/Makefile b/archivers/py-attic/Makefile
index 75e0987030ff..eb1476e5ea10 100644
--- a/archivers/py-attic/Makefile
+++ b/archivers/py-attic/Makefile
@@ -25,7 +25,8 @@ PYDISTUTILS_BUILDPATH=${BUILD_WRKSRC}/build/lib.${OPSYS:tl}-${UNAMER}-${ARCH}-${
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/archivers/py-borgbackup/Makefile b/archivers/py-borgbackup/Makefile
index d99215373938..50e6703a9893 100644
--- a/archivers/py-borgbackup/Makefile
+++ b/archivers/py-borgbackup/Makefile
@@ -28,7 +28,8 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/audio/lollypop/Makefile b/audio/lollypop/Makefile
index 57e73ebee35a..83ffb6c3de8a 100644
--- a/audio/lollypop/Makefile
+++ b/audio/lollypop/Makefile
@@ -37,7 +37,8 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/comms/wsjt/Makefile b/comms/wsjt/Makefile
index 27dd2dd9fd3b..f20e3d8d7e44 100644
--- a/comms/wsjt/Makefile
+++ b/comms/wsjt/Makefile
@@ -103,7 +103,8 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${d} ${STAGEDIR}${DOCSDIR}
.endfor
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index 9661010c0618..ba67d41f78c0 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -63,7 +63,8 @@ do-fetch:
.endif
.endif
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/mail/rss2email3/Makefile b/mail/rss2email3/Makefile
index 55246947caf3..e80fe7fc265e 100644
--- a/mail/rss2email3/Makefile
+++ b/mail/rss2email3/Makefile
@@ -35,7 +35,8 @@ post-install:
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/math/convertall/Makefile b/math/convertall/Makefile
index 8453cbb651ee..5ab4221d4618 100644
--- a/math/convertall/Makefile
+++ b/math/convertall/Makefile
@@ -41,7 +41,8 @@ do-install:
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/math/rpcalc/Makefile b/math/rpcalc/Makefile
index ab158bdb1199..b8af31587762 100644
--- a/math/rpcalc/Makefile
+++ b/math/rpcalc/Makefile
@@ -36,7 +36,8 @@ do-install:
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/multimedia/mps-youtube/Makefile b/multimedia/mps-youtube/Makefile
index 87d43cdcb365..f3d85f2779a8 100644
--- a/multimedia/mps-youtube/Makefile
+++ b/multimedia/mps-youtube/Makefile
@@ -46,7 +46,8 @@ post-install:
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/net-im/poezio/Makefile b/net-im/poezio/Makefile
index 6df03c904d7f..457ff01c1a40 100644
--- a/net-im/poezio/Makefile
+++ b/net-im/poezio/Makefile
@@ -20,7 +20,8 @@ USE_PYTHON= distutils autoplist
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/net/tiny-network-utilities/Makefile b/net/tiny-network-utilities/Makefile
index 7ff77903d147..282d11151313 100644
--- a/net/tiny-network-utilities/Makefile
+++ b/net/tiny-network-utilities/Makefile
@@ -27,7 +27,8 @@ PLIST_FILES= ${FILES_EXEC:%=bin/%} ${FILES_LIB:%=${PYTHON_SITELIBDIR}/%.py}
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/ports-mgmt/py-pytoport/Makefile b/ports-mgmt/py-pytoport/Makefile
index 7dd190b48e63..51e67535120d 100644
--- a/ports-mgmt/py-pytoport/Makefile
+++ b/ports-mgmt/py-pytoport/Makefile
@@ -25,7 +25,8 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif
diff --git a/security/morphis/Makefile b/security/morphis/Makefile
index 9d3554f81442..851d2b906a4b 100644
--- a/security/morphis/Makefile
+++ b/security/morphis/Makefile
@@ -27,7 +27,8 @@ NO_ARCH= yes
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
+ ${PYTHON_VER} != ${PYTHON_DEFAULT}
IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
.endif