aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/slimserver/Makefile1
-rw-r--r--audio/slimserver/files/patch-Bin_build-perl-modules.pl22
-rw-r--r--audio/squeezeboxserver/Makefile1
-rw-r--r--audio/squeezeboxserver/files/patch-Bin_build-perl-modules.pl22
-rw-r--r--audio/squeezecenter/Makefile1
-rw-r--r--audio/squeezecenter/files/patch-Bin_build-perl-modules.pl22
6 files changed, 57 insertions, 12 deletions
diff --git a/audio/slimserver/Makefile b/audio/slimserver/Makefile
index 5d054ed2b1f0..f6bcc1a8b863 100644
--- a/audio/slimserver/Makefile
+++ b/audio/slimserver/Makefile
@@ -90,6 +90,7 @@ post-fetch:
post-patch:
${REINPLACE_CMD} \
-e 's|%%PERL%%|${PERL}|' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|%%TMP_SLIMDIR%%|${TMP_SLIMDIR}|' \
-e 's|%%CPANWRKDIR%%|${CPANWRKDIR}|' \
-e 's|%%DISTDIR%%|${_DISTDIR}|' ${WRKSRC}/Bin/build-perl-modules.pl
diff --git a/audio/slimserver/files/patch-Bin_build-perl-modules.pl b/audio/slimserver/files/patch-Bin_build-perl-modules.pl
index 4e2fab43e13f..0c4f4afcf27f 100644
--- a/audio/slimserver/files/patch-Bin_build-perl-modules.pl
+++ b/audio/slimserver/files/patch-Bin_build-perl-modules.pl
@@ -3,7 +3,21 @@ $FreeBSD$
--- Bin/build-perl-modules.pl.orig
+++ Bin/build-perl-modules.pl
-@@ -74,28 +74,30 @@
+@@ -54,6 +54,13 @@
+
+ 'env' => [qw(DBI-1.46/blib/lib: DBI-1.46/blib/arch)],
+ },
++
++ 'XML-Parser-2.34' => {
++ 'Makefile.PL' => join(' ', qw(
++ EXPATLIBPATH="%%LOCALBASE%%/lib"
++ EXPATINCPATH="%%LOCALBASE%%/include"
++ )),
++ },
+ );
+
+ sub main {
+@@ -74,28 +81,30 @@
print "*** Ignore any warnings about AppConfig. ***\n\n";
@@ -51,7 +65,7 @@ $FreeBSD$
unless (-d $slimServerPath) {
die "Couldn't find a valid SlimServer path. Exiting.\n";
-@@ -104,12 +106,13 @@
+@@ -107,12 +116,13 @@
# This is where the binaries will end up.
my $cpanDest = "$slimServerPath/CPAN/arch/$version/$archname/auto";
@@ -71,7 +85,7 @@ $FreeBSD$
# Remove trailing slash
$downloadPath =~ s|^(.+?)/$|$1|;
-@@ -122,32 +125,32 @@
+@@ -125,32 +135,32 @@
my $pwd = cwd();
@@ -130,7 +144,7 @@ $FreeBSD$
for my $package (@packages) {
-@@ -158,18 +161,19 @@
+@@ -161,18 +171,19 @@
# Remove any previous version.
unlink $package;
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 5d054ed2b1f0..f6bcc1a8b863 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -90,6 +90,7 @@ post-fetch:
post-patch:
${REINPLACE_CMD} \
-e 's|%%PERL%%|${PERL}|' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|%%TMP_SLIMDIR%%|${TMP_SLIMDIR}|' \
-e 's|%%CPANWRKDIR%%|${CPANWRKDIR}|' \
-e 's|%%DISTDIR%%|${_DISTDIR}|' ${WRKSRC}/Bin/build-perl-modules.pl
diff --git a/audio/squeezeboxserver/files/patch-Bin_build-perl-modules.pl b/audio/squeezeboxserver/files/patch-Bin_build-perl-modules.pl
index 4e2fab43e13f..0c4f4afcf27f 100644
--- a/audio/squeezeboxserver/files/patch-Bin_build-perl-modules.pl
+++ b/audio/squeezeboxserver/files/patch-Bin_build-perl-modules.pl
@@ -3,7 +3,21 @@ $FreeBSD$
--- Bin/build-perl-modules.pl.orig
+++ Bin/build-perl-modules.pl
-@@ -74,28 +74,30 @@
+@@ -54,6 +54,13 @@
+
+ 'env' => [qw(DBI-1.46/blib/lib: DBI-1.46/blib/arch)],
+ },
++
++ 'XML-Parser-2.34' => {
++ 'Makefile.PL' => join(' ', qw(
++ EXPATLIBPATH="%%LOCALBASE%%/lib"
++ EXPATINCPATH="%%LOCALBASE%%/include"
++ )),
++ },
+ );
+
+ sub main {
+@@ -74,28 +81,30 @@
print "*** Ignore any warnings about AppConfig. ***\n\n";
@@ -51,7 +65,7 @@ $FreeBSD$
unless (-d $slimServerPath) {
die "Couldn't find a valid SlimServer path. Exiting.\n";
-@@ -104,12 +106,13 @@
+@@ -107,12 +116,13 @@
# This is where the binaries will end up.
my $cpanDest = "$slimServerPath/CPAN/arch/$version/$archname/auto";
@@ -71,7 +85,7 @@ $FreeBSD$
# Remove trailing slash
$downloadPath =~ s|^(.+?)/$|$1|;
-@@ -122,32 +125,32 @@
+@@ -125,32 +135,32 @@
my $pwd = cwd();
@@ -130,7 +144,7 @@ $FreeBSD$
for my $package (@packages) {
-@@ -158,18 +161,19 @@
+@@ -161,18 +171,19 @@
# Remove any previous version.
unlink $package;
diff --git a/audio/squeezecenter/Makefile b/audio/squeezecenter/Makefile
index 5d054ed2b1f0..f6bcc1a8b863 100644
--- a/audio/squeezecenter/Makefile
+++ b/audio/squeezecenter/Makefile
@@ -90,6 +90,7 @@ post-fetch:
post-patch:
${REINPLACE_CMD} \
-e 's|%%PERL%%|${PERL}|' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|%%TMP_SLIMDIR%%|${TMP_SLIMDIR}|' \
-e 's|%%CPANWRKDIR%%|${CPANWRKDIR}|' \
-e 's|%%DISTDIR%%|${_DISTDIR}|' ${WRKSRC}/Bin/build-perl-modules.pl
diff --git a/audio/squeezecenter/files/patch-Bin_build-perl-modules.pl b/audio/squeezecenter/files/patch-Bin_build-perl-modules.pl
index 4e2fab43e13f..0c4f4afcf27f 100644
--- a/audio/squeezecenter/files/patch-Bin_build-perl-modules.pl
+++ b/audio/squeezecenter/files/patch-Bin_build-perl-modules.pl
@@ -3,7 +3,21 @@ $FreeBSD$
--- Bin/build-perl-modules.pl.orig
+++ Bin/build-perl-modules.pl
-@@ -74,28 +74,30 @@
+@@ -54,6 +54,13 @@
+
+ 'env' => [qw(DBI-1.46/blib/lib: DBI-1.46/blib/arch)],
+ },
++
++ 'XML-Parser-2.34' => {
++ 'Makefile.PL' => join(' ', qw(
++ EXPATLIBPATH="%%LOCALBASE%%/lib"
++ EXPATINCPATH="%%LOCALBASE%%/include"
++ )),
++ },
+ );
+
+ sub main {
+@@ -74,28 +81,30 @@
print "*** Ignore any warnings about AppConfig. ***\n\n";
@@ -51,7 +65,7 @@ $FreeBSD$
unless (-d $slimServerPath) {
die "Couldn't find a valid SlimServer path. Exiting.\n";
-@@ -104,12 +106,13 @@
+@@ -107,12 +116,13 @@
# This is where the binaries will end up.
my $cpanDest = "$slimServerPath/CPAN/arch/$version/$archname/auto";
@@ -71,7 +85,7 @@ $FreeBSD$
# Remove trailing slash
$downloadPath =~ s|^(.+?)/$|$1|;
-@@ -122,32 +125,32 @@
+@@ -125,32 +135,32 @@
my $pwd = cwd();
@@ -130,7 +144,7 @@ $FreeBSD$
for my $package (@packages) {
-@@ -158,18 +161,19 @@
+@@ -161,18 +171,19 @@
# Remove any previous version.
unlink $package;