aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/plasma6-spectacle/files/extra-patch-pipewire-off24
1 files changed, 12 insertions, 12 deletions
diff --git a/graphics/plasma6-spectacle/files/extra-patch-pipewire-off b/graphics/plasma6-spectacle/files/extra-patch-pipewire-off
index 7c21c8d198e8..ee69ca424239 100644
--- a/graphics/plasma6-spectacle/files/extra-patch-pipewire-off
+++ b/graphics/plasma6-spectacle/files/extra-patch-pipewire-off
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2025-01-30 23:53:22 UTC
+--- CMakeLists.txt.orig 2025-02-19 09:24:17 UTC
+++ CMakeLists.txt
-@@ -86,12 +86,16 @@ find_package(LayerShellQt REQUIRED)
+@@ -83,12 +83,16 @@ find_package(LayerShellQt REQUIRED)
find_package(Wayland REQUIRED COMPONENTS Client)
find_package(PlasmaWaylandProtocols REQUIRED)
find_package(LayerShellQt REQUIRED)
@@ -19,20 +19,20 @@
)
# optional components
---- src/CMakeLists.txt.orig 2025-01-30 23:53:22 UTC
+--- src/CMakeLists.txt.orig 2025-02-19 09:24:17 UTC
+++ src/CMakeLists.txt
-@@ -16,6 +16,10 @@ ecm_qt_declare_logging_category(SPECTACLE_SRCS
- EXPORT SPECTACLE
- )
+@@ -19,6 +19,10 @@ qt_add_qml_module(spectacle URI ${SPECTACLE_QML_URI} D
+ add_executable(spectacle)
+ qt_add_qml_module(spectacle URI ${SPECTACLE_QML_URI} DEPENDENCIES QtCore QtQuick)
+if(PIPEWIRE_FOUND)
+ list(APPEND SPECTACLE_SRCS Platforms/VideoPlatformWayland.cpp)
+endif()
+
- add_executable(spectacle
+ target_sources(spectacle PRIVATE
${SPECTACLE_SRCS}
Main.cpp
-@@ -58,7 +62,6 @@ add_executable(spectacle
+@@ -61,7 +65,6 @@ target_sources(spectacle PRIVATE
Platforms/PlatformNull.cpp
Platforms/ImagePlatformKWin.cpp
Platforms/VideoPlatform.cpp
@@ -40,7 +40,7 @@
Platforms/screencasting.cpp
)
-@@ -99,6 +102,10 @@ target_include_directories(spectacle PUBLIC ${OpenCV_I
+@@ -102,6 +105,10 @@ target_include_directories(spectacle PUBLIC ${OpenCV_I
target_include_directories(spectacle PUBLIC ${OpenCV_INCLUDE_DIRS})
@@ -51,7 +51,7 @@
target_link_libraries(spectacle PRIVATE
Qt::Concurrent
Qt::DBus
-@@ -124,7 +131,6 @@ target_link_libraries(spectacle PRIVATE
+@@ -127,7 +134,6 @@ target_link_libraries(spectacle PRIVATE
KF6::StatusNotifierItem
KF6::PrisonScanner
KF6::Crash
@@ -59,7 +59,7 @@
Wayland::Client
LayerShellQt::Interface
${OpenCV_LIBRARIES}
---- src/Config.h.in.orig 2025-01-30 23:53:22 UTC
+--- src/Config.h.in.orig 2025-02-19 09:24:17 UTC
+++ src/Config.h.in
@@ -7,6 +7,9 @@
/* Define to 1 if we have Purpose */
@@ -71,7 +71,7 @@
/* Set the Spectacle version from CMake */
#cmakedefine SPECTACLE_VERSION "@SPECTACLE_VERSION@"
---- src/Platforms/PlatformLoader.cpp.orig 2025-01-30 23:53:22 UTC
+--- src/Platforms/PlatformLoader.cpp.orig 2025-02-19 09:24:17 UTC
+++ src/Platforms/PlatformLoader.cpp
@@ -11,7 +11,9 @@