aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/thunderbird-esr/Makefile1
-rw-r--r--mail/thunderbird-esr/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--mail/thunderbird3/Makefile1
-rw-r--r--mail/thunderbird3/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--sysutils/flock/Makefile1
-rw-r--r--sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/firefox15/Makefile3
-rw-r--r--www/firefox15/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/firefox36/Makefile2
-rw-r--r--www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/kompozer/Makefile3
-rw-r--r--www/kompozer/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/mozilla/Makefile3
-rw-r--r--www/mozilla/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/nvu/Makefile3
-rw-r--r--www/nvu/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/seamonkey/Makefile1
-rw-r--r--www/seamonkey/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/seamonkey2/Makefile1
-rw-r--r--www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp18
-rw-r--r--www/xulrunner/Makefile3
-rw-r--r--www/xulrunner/files/patch-widget_src_gtk2_nsDragService.cpp18
28 files changed, 274 insertions, 5 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 87999415623c..acd11e267ec5 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -8,6 +8,7 @@
PORTNAME= thunderbird
DISTVERSION= 1.5.0.9
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird-esr/files/patch-widget_src_gtk2_nsDragService.cpp b/mail/thunderbird-esr/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/mail/thunderbird-esr/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 87999415623c..acd11e267ec5 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -8,6 +8,7 @@
PORTNAME= thunderbird
DISTVERSION= 1.5.0.9
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp b/mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 87999415623c..acd11e267ec5 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= thunderbird
DISTVERSION= 1.5.0.9
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird3/files/patch-widget_src_gtk2_nsDragService.cpp b/mail/thunderbird3/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/mail/thunderbird3/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/sysutils/flock/Makefile b/sysutils/flock/Makefile
index 93d03cf2e782..d5c1dff568ef 100644
--- a/sysutils/flock/Makefile
+++ b/sysutils/flock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flock
PORTVERSION= 3.4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
http://archive.progeny.com/pundits/
diff --git a/sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp b/sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index c0455b866809..66e0ef4763c2 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,9 +4,11 @@
#
# $FreeBSD$
# $MCom: ports-stable/www/firefox/Makefile,v 1.21 2006/10/25 01:20:12 ahze Exp $
+#
PORTNAME= firefox
DISTVERSION= 2.0.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
diff --git a/www/firefox-esr/files/patch-widget_src_gtk2_nsDragService.cpp b/www/firefox-esr/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/firefox-esr/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index c0455b866809..66e0ef4763c2 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,9 +4,11 @@
#
# $FreeBSD$
# $MCom: ports-stable/www/firefox/Makefile,v 1.21 2006/10/25 01:20:12 ahze Exp $
+#
PORTNAME= firefox
DISTVERSION= 2.0.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
diff --git a/www/firefox/files/patch-widget_src_gtk2_nsDragService.cpp b/www/firefox/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/firefox/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index 8abeddc3e343..77c792c20b24 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -4,10 +4,11 @@
#
# $FreeBSD$
# $MCom: ports-stable/www/firefox15/Makefile,v 1.21 2006/10/24 17:48:39 ahze Exp $
+#
PORTNAME= firefox
DISTVERSION= 1.5.0.9
-PORTEPOCH= 2
+PORTEPOCH= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
diff --git a/www/firefox15/files/patch-widget_src_gtk2_nsDragService.cpp b/www/firefox15/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/firefox15/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index c0455b866809..66e0ef4763c2 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -4,9 +4,11 @@
#
# $FreeBSD$
# $MCom: ports-stable/www/firefox/Makefile,v 1.21 2006/10/25 01:20:12 ahze Exp $
+#
PORTNAME= firefox
DISTVERSION= 2.0.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
diff --git a/www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp b/www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/kompozer/Makefile b/www/kompozer/Makefile
index 56311018052f..0352bc8f7124 100644
--- a/www/kompozer/Makefile
+++ b/www/kompozer/Makefile
@@ -4,10 +4,11 @@
#
# $FreeBSD$
# $MCom: ports/www/nvu/Makefile,v 1.5 2006/07/18 15:07:36 ahze Exp $
+#
PORTNAME= nvu
DISTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://cvs.nvu.com/download/
DISTNAME= ${PORTNAME}-${DISTVERSION}-sources
diff --git a/www/kompozer/files/patch-widget_src_gtk2_nsDragService.cpp b/www/kompozer/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/kompozer/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index f60906ca05f9..0980ea18121e 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -4,10 +4,11 @@
#
# $FreeBSD$
# $MCom: ports-stable/www/mozilla/Makefile,v 1.15 2006/10/18 17:29:07 ahze Exp $
+#
PORTNAME= mozilla
PORTVERSION= 1.7.13
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/mozilla/files/patch-widget_src_gtk2_nsDragService.cpp b/www/mozilla/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/mozilla/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/nvu/Makefile b/www/nvu/Makefile
index 56311018052f..0352bc8f7124 100644
--- a/www/nvu/Makefile
+++ b/www/nvu/Makefile
@@ -4,10 +4,11 @@
#
# $FreeBSD$
# $MCom: ports/www/nvu/Makefile,v 1.5 2006/07/18 15:07:36 ahze Exp $
+#
PORTNAME= nvu
DISTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://cvs.nvu.com/download/
DISTNAME= ${PORTNAME}-${DISTVERSION}-sources
diff --git a/www/nvu/files/patch-widget_src_gtk2_nsDragService.cpp b/www/nvu/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/nvu/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index e82fa707f775..ef959d531d47 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -8,6 +8,7 @@
PORTNAME= seamonkey
DISTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES?= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}
diff --git a/www/seamonkey/files/patch-widget_src_gtk2_nsDragService.cpp b/www/seamonkey/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/seamonkey/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index e82fa707f775..ef959d531d47 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -8,6 +8,7 @@
PORTNAME= seamonkey
DISTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES?= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}
diff --git a/www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp b/www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void
diff --git a/www/xulrunner/Makefile b/www/xulrunner/Makefile
index 199dec56c613..819bab3d5e3c 100644
--- a/www/xulrunner/Makefile
+++ b/www/xulrunner/Makefile
@@ -4,10 +4,11 @@
#
# $FreeBSD$
# $MCom: ports/www/xulrunner/Makefile,v 1.13 2006/10/12 12:22:03 ahze Exp $
+#
PORTNAME= xulrunner
PORTVERSION= 1.8.0.4
-PORTREVISION?= 5
+PORTREVISION?= 6
CATEGORIES?= www devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= xulrunner/releases/${PORTVERSION}/source/
diff --git a/www/xulrunner/files/patch-widget_src_gtk2_nsDragService.cpp b/www/xulrunner/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/xulrunner/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void