aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/calibre/Makefile5
-rw-r--r--deskutils/calibre/distinfo6
-rw-r--r--deskutils/calibre/pkg-plist23
3 files changed, 24 insertions, 10 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index 64ca8b28438a..c97aab6a2973 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 4.5.0
+PORTVERSION= 4.6.0
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
@@ -19,7 +19,8 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libpodofo.so:graphics/podofo \
libmtp.so:multimedia/libmtp \
libfreetype.so:print/freetype2 \
- libhunspell-1.7.so:textproc/hunspell
+ libhunspell-1.7.so:textproc/hunspell \
+ libhyphen.so:textproc/hyphen
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index 1bfa377d572f..010977f5a82b 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1574980687
-SHA256 (calibre-4.5.0.tar.xz) = 8c894bd38ed3f14de9723f6a78db81791c8b5cd27cffd36b37bf79a2fc15e78e
-SIZE (calibre-4.5.0.tar.xz) = 36472092
+TIMESTAMP = 1576187782
+SHA256 (calibre-4.6.0.tar.xz) = a602ab5b4e14944d81311ef680c5fa8eff1f073368df075d3d46700e5f2e0aed
+SIZE (calibre-4.6.0.tar.xz) = 37397188
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index 4230b886df6b..9b163030de42 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -449,6 +449,7 @@ lib/calibre/calibre/ebooks/oeb/polish/download.py
lib/calibre/calibre/ebooks/oeb/polish/embed.py
lib/calibre/calibre/ebooks/oeb/polish/errors.py
lib/calibre/calibre/ebooks/oeb/polish/fonts.py
+lib/calibre/calibre/ebooks/oeb/polish/hyphenation.py
lib/calibre/calibre/ebooks/oeb/polish/images.py
lib/calibre/calibre/ebooks/oeb/polish/import_book.py
lib/calibre/calibre/ebooks/oeb/polish/jacket.py
@@ -874,6 +875,7 @@ lib/calibre/calibre/gui2/metadata/single.py
lib/calibre/calibre/gui2/metadata/single_download.py
lib/calibre/calibre/gui2/notify.py
lib/calibre/calibre/gui2/open_with.py
+lib/calibre/calibre/gui2/palette.py
lib/calibre/calibre/gui2/pin_columns.py
lib/calibre/calibre/gui2/preferences/__init__.py
lib/calibre/calibre/gui2/preferences/adding.py
@@ -1142,9 +1144,10 @@ lib/calibre/calibre/plugins/cPalmdoc.so
lib/calibre/calibre/plugins/certgen.so
lib/calibre/calibre/plugins/chmlib.so
lib/calibre/calibre/plugins/freetype.so
-lib/calibre/calibre/plugins/html.so
lib/calibre/calibre/plugins/html_as_json.so
+lib/calibre/calibre/plugins/html_syntax_highlighter.so
lib/calibre/calibre/plugins/hunspell.so
+lib/calibre/calibre/plugins/hyphen.so
lib/calibre/calibre/plugins/icu.so
lib/calibre/calibre/plugins/imageops.so
lib/calibre/calibre/plugins/libheadless.so
@@ -1263,6 +1266,10 @@ lib/calibre/calibre/utils/formatter.py
lib/calibre/calibre/utils/formatter_functions.py
lib/calibre/calibre/utils/html2text.py
lib/calibre/calibre/utils/https.py
+lib/calibre/calibre/utils/hyphenation/__init__.py
+lib/calibre/calibre/utils/hyphenation/dictionaries.py
+lib/calibre/calibre/utils/hyphenation/hyphenate.py
+lib/calibre/calibre/utils/hyphenation/test_hyphenation.py
lib/calibre/calibre/utils/icu.py
lib/calibre/calibre/utils/icu_test.py
lib/calibre/calibre/utils/img.py
@@ -1350,16 +1357,16 @@ lib/calibre/calibre/web/feeds/templates.py
lib/calibre/calibre/web/fetch/__init__.py
lib/calibre/calibre/web/fetch/simple.py
lib/calibre/calibre/web/fetch/utils.py
+lib/calibre/calibre_lzma/__init__.py
+lib/calibre/calibre_lzma/errors.py
+lib/calibre/calibre_lzma/lzma1.py
+lib/calibre/calibre_lzma/xz.py
lib/calibre/css_selectors/__init__.py
lib/calibre/css_selectors/errors.py
lib/calibre/css_selectors/ordered_set.py
lib/calibre/css_selectors/parser.py
lib/calibre/css_selectors/select.py
lib/calibre/css_selectors/tests.py
-lib/calibre/lzma/__init__.py
-lib/calibre/lzma/errors.py
-lib/calibre/lzma/lzma1.py
-lib/calibre/lzma/xz.py
lib/calibre/odf/__init__.py
lib/calibre/odf/anim.py
lib/calibre/odf/attrconverters.py
@@ -1482,6 +1489,9 @@ lib/calibre/tinycss/version.py
%%DATADIR%%/fonts/liberation/LiberationSerif-BoldItalic.ttf
%%DATADIR%%/fonts/liberation/LiberationSerif-Italic.ttf
%%DATADIR%%/fonts/liberation/LiberationSerif-Regular.ttf
+%%DATADIR%%/hyphenation/dictionaries.tar.xz
+%%DATADIR%%/hyphenation/locales.json
+%%DATADIR%%/hyphenation/sha1sum
%%DATADIR%%/images.qrc
%%DATADIR%%/images/add_book.png
%%DATADIR%%/images/apple-touch-icon.png
@@ -1576,6 +1586,7 @@ lib/calibre/tinycss/version.py
%%DATADIR%%/images/generic-library.png
%%DATADIR%%/images/gmail_logo.png
%%DATADIR%%/images/grid.png
+%%DATADIR%%/images/h-ellipsis.png
%%DATADIR%%/images/help.png
%%DATADIR%%/images/heuristics.png
%%DATADIR%%/images/highlight_only_off.png
@@ -1662,6 +1673,7 @@ lib/calibre/tinycss/version.py
%%DATADIR%%/images/random.png
%%DATADIR%%/images/rating.png
%%DATADIR%%/images/reader.png
+%%DATADIR%%/images/reference.png
%%DATADIR%%/images/remove_books.png
%%DATADIR%%/images/reports.png
%%DATADIR%%/images/resize.png
@@ -1701,6 +1713,7 @@ lib/calibre/tinycss/version.py
%%DATADIR%%/images/tweaks.png
%%DATADIR%%/images/unpack-book.png
%%DATADIR%%/images/user_profile.png
+%%DATADIR%%/images/v-ellipsis.png
%%DATADIR%%/images/view-image.png
%%DATADIR%%/images/view-refresh.png
%%DATADIR%%/images/view.png