aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING8
-rw-r--r--lang/python24/Makefile8
-rw-r--r--lang/python25/Makefile7
-rw-r--r--lang/python26/Makefile7
-rw-r--r--lang/python27/Makefile8
-rw-r--r--lang/python31/Makefile7
-rw-r--r--lang/python32/Makefile7
7 files changed, 14 insertions, 38 deletions
diff --git a/UPDATING b/UPDATING
index c77ca6a3d913..574efe5c86c7 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,14 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20110925:
+ AFFECTS: users of lang/python*
+ AUTHOR: lwhsu@FreeBSD.org
+
+ The HUGE_STACK_SIZE option has been removed, now Python will use default
+ thread stack size of the system. If you want to change it, specify it
+ with -DTHREAD_STACK_SIZE=<size> in CFLAGS.
+
+20110925:
AFFECTS: users of net/openldap*
AUTHOR: ume@FreeBSD.org
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 3d2dfb45427d..dec843e3ddac 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python24
PORTVERSION= 2.4.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -43,7 +43,6 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Use python's internal malloc" on \
IPV6 "Enable IPv6 support" on \
@@ -64,11 +63,6 @@ CFLAGS+= -D__wchar_t=wchar_t
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
LDFLAGS+= ${PTHREAD_LIBS}
.else
CONFIGURE_ARGS+= --without-threads
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 7fd4f7ee198c..0a0560ced7a7 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python25
PORTVERSION= 2.5.6
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -47,7 +48,6 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Use python's internal malloc" on \
IPV6 "Enable IPv6 support" on \
@@ -68,11 +68,6 @@ CFLAGS+= -D__wchar_t=wchar_t
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
LDFLAGS+= ${PTHREAD_LIBS}
.else
CONFIGURE_ARGS+= --without-threads
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index dfc413af7b28..38be184fff72 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python26
PORTVERSION= 2.6.7
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -48,7 +49,6 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
SEM "Use POSIX semaphores (experimental)" off \
PTH "Use GNU Pth for threading/multiprocessing" off \
UCS4 "Use UCS4 for unicode support" on \
@@ -96,11 +96,6 @@ CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
.endif # defined(WITH_PTH)
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
.else # defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS="@comment "
CONFIGURE_ARGS+= --without-threads
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index b4a9a139cdea..6803069c26e8 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -6,7 +6,7 @@
PORTNAME= python27
PORTVERSION= 2.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -49,7 +49,6 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
SEM "Use POSIX semaphores (experimental)" off \
PTH "Use GNU Pth for threading/multiprocessing" off \
UCS4 "Use UCS4 for unicode support" on \
@@ -98,11 +97,6 @@ CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
.endif # defined(WITH_PTH)
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
.else # defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS="@comment "
CONFIGURE_ARGS+= --without-threads
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 54279db975e5..3b262749ac10 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python31
PORTVERSION= 3.1.4
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -48,7 +49,6 @@ BINLINKS_SUB= -e 's,(2to3|idle3|pydoc3),\1-${PYTHON_VER},' \
-e 's,(python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Use python's internal malloc" on \
IPV6 "Enable IPv6 support" on \
@@ -70,11 +70,6 @@ CFLAGS+= -D__wchar_t=wchar_t
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
LDFLAGS+= ${PTHREAD_LIBS}
.else # defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS="@comment "
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 85939aaf5095..8d2ebe779c75 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python32
PORTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -49,7 +50,6 @@ BINLINKS_SUB= -e 's,(2to3|idle3|pydoc3),\1-${PYTHON_VER},' \
-e 's,(python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Use python's internal malloc" on \
IPV6 "Enable IPv6 support" on \
@@ -71,11 +71,6 @@ CFLAGS+= -D__wchar_t=wchar_t
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
LDFLAGS+= ${PTHREAD_LIBS}
.else # defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS="@comment "