aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/filezilla/Makefile26
-rw-r--r--ftp/filezilla/distinfo4
-rw-r--r--ftp/filezilla/pkg-plist105
3 files changed, 114 insertions, 21 deletions
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index 75f25088b67e..a3641d3027f8 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= filezilla
-PORTVERSION= 3.5.3
-PORTREVISION= 1
+PORTVERSION= 3.6.0.1
CATEGORIES= ftp
MASTER_SITES= SF/${PORTNAME}/FileZilla_Client/${PORTVERSION}
DISTNAME= FileZilla_${PORTVERSION}_src
@@ -16,21 +15,20 @@ MAINTAINER= jsa@FreeBSD.org
COMMENT= Fast and reliable cross-platform FTP, FTPS, and SFTP client
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
BUILD_DEPENDS:= ${RUN_DEPENDS}
-LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt \
- gnutls.47:${PORTSDIR}/security/gnutls \
- idn.17:${PORTSDIR}/dns/libidn \
- sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- tinyxml.3:${PORTSDIR}/textproc/tinyxml
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
+ gnutls:${PORTSDIR}/security/gnutls \
+ idn:${PORTSDIR}/dns/libidn \
+ tinyxml:${PORTSDIR}/textproc/tinyxml
MAKE_JOBS_SAFE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_SQLITE= 3
USE_WX= 2.8
WX_CONF_ARGS= relative
WX_UNICODE= yes
@@ -42,17 +40,19 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= filezilla.1 fzputtygen.1 fzsftp.1
MAN5= fzdefaults.xml.5
-OPTIONS= DBUS "Enable D-BUS intergration" On \
- NLS "Native Language Support" On
+OPTIONS_DEFINE= DBUS NLS
+OPTIONS_DEFAULT=DBUS NLS
-.if !defined(WITHOUT_DBUS)
-LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDBUS}
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
CONFIGURE_ARGS+= --with-dbus
.else
CONFIGURE_ARGS+= --without-dbus
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/ftp/filezilla/distinfo b/ftp/filezilla/distinfo
index 7312455a2a90..c2234b496a44 100644
--- a/ftp/filezilla/distinfo
+++ b/ftp/filezilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FileZilla_3.5.3_src.tar.bz2) = 0bba27baa2041fd926f9775e360e70af391cdec10f3f3b1a8dff20b3e100ff6b
-SIZE (FileZilla_3.5.3_src.tar.bz2) = 3366662
+SHA256 (FileZilla_3.6.0.1_src.tar.bz2) = ca15eded526bc3e2412cc7f74e89b98a59bf1ea92a432de420d391046a2822f0
+SIZE (FileZilla_3.6.0.1_src.tar.bz2) = 3534874
diff --git a/ftp/filezilla/pkg-plist b/ftp/filezilla/pkg-plist
index 24c695e6a721..a8d801ffd160 100644
--- a/ftp/filezilla/pkg-plist
+++ b/ftp/filezilla/pkg-plist
@@ -28,6 +28,7 @@ bin/fzputtygen
%%NLS%%share/locale/km_KH/LC_MESSAGES/filezilla.mo
%%NLS%%share/locale/ko_KR/LC_MESSAGES/filezilla.mo
%%NLS%%share/locale/ku/LC_MESSAGES/filezilla.mo
+%%NLS%%share/locale/ky/LC_MESSAGES/filezilla.mo
%%NLS%%share/locale/lt_LT/LC_MESSAGES/filezilla.mo
%%NLS%%share/locale/lv_LV/LC_MESSAGES/filezilla.mo
%%NLS%%share/locale/mk_MK/LC_MESSAGES/filezilla.mo
@@ -217,7 +218,7 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/lone/16x16/ascii.png
%%DATADIR%%/resources/lone/16x16/auto.png
%%DATADIR%%/resources/lone/16x16/binary.png
-%%DATADIR%%/resources/lone/16x16/bookmarks.png
+%%DATADIR%%/resources/lone/16x16/bookmark.png
%%DATADIR%%/resources/lone/16x16/cancel.png
%%DATADIR%%/resources/lone/16x16/compare.png
%%DATADIR%%/resources/lone/16x16/disconnect.png
@@ -248,7 +249,7 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/lone/32x32/ascii.png
%%DATADIR%%/resources/lone/32x32/auto.png
%%DATADIR%%/resources/lone/32x32/binary.png
-%%DATADIR%%/resources/lone/32x32/bookmarks.png
+%%DATADIR%%/resources/lone/32x32/bookmark.png
%%DATADIR%%/resources/lone/32x32/cancel.png
%%DATADIR%%/resources/lone/32x32/compare.png
%%DATADIR%%/resources/lone/32x32/disconnect.png
@@ -278,7 +279,7 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/lone/48x48/ascii.png
%%DATADIR%%/resources/lone/48x48/auto.png
%%DATADIR%%/resources/lone/48x48/binary.png
-%%DATADIR%%/resources/lone/48x48/bookmarks.png
+%%DATADIR%%/resources/lone/48x48/bookmark.png
%%DATADIR%%/resources/lone/48x48/cancel.png
%%DATADIR%%/resources/lone/48x48/compare.png
%%DATADIR%%/resources/lone/48x48/disconnect.png
@@ -343,7 +344,7 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/opencrystal/16x16/ascii.png
%%DATADIR%%/resources/opencrystal/16x16/auto.png
%%DATADIR%%/resources/opencrystal/16x16/binary.png
-%%DATADIR%%/resources/opencrystal/16x16/bookmarks.png
+%%DATADIR%%/resources/opencrystal/16x16/bookmark.png
%%DATADIR%%/resources/opencrystal/16x16/cancel.png
%%DATADIR%%/resources/opencrystal/16x16/compare.png
%%DATADIR%%/resources/opencrystal/16x16/disconnect.png
@@ -377,7 +378,7 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/opencrystal/32x32/ascii.png
%%DATADIR%%/resources/opencrystal/32x32/auto.png
%%DATADIR%%/resources/opencrystal/32x32/binary.png
-%%DATADIR%%/resources/opencrystal/32x32/bookmarks.png
+%%DATADIR%%/resources/opencrystal/32x32/bookmark.png
%%DATADIR%%/resources/opencrystal/32x32/cancel.png
%%DATADIR%%/resources/opencrystal/32x32/compare.png
%%DATADIR%%/resources/opencrystal/32x32/disconnect.png
@@ -408,7 +409,7 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/opencrystal/48x48/ascii.png
%%DATADIR%%/resources/opencrystal/48x48/auto.png
%%DATADIR%%/resources/opencrystal/48x48/binary.png
-%%DATADIR%%/resources/opencrystal/48x48/bookmarks.png
+%%DATADIR%%/resources/opencrystal/48x48/bookmark.png
%%DATADIR%%/resources/opencrystal/48x48/cancel.png
%%DATADIR%%/resources/opencrystal/48x48/compare.png
%%DATADIR%%/resources/opencrystal/48x48/disconnect.png
@@ -437,6 +438,91 @@ share/pixmaps/filezilla.png
%%DATADIR%%/resources/opencrystal/48x48/upload.png
%%DATADIR%%/resources/opencrystal/48x48/uploadadd.png
%%DATADIR%%/resources/opencrystal/theme.xml
+%%DATADIR%%/resources/tango/16x16/ascii.png
+%%DATADIR%%/resources/tango/16x16/auto.png
+%%DATADIR%%/resources/tango/16x16/binary.png
+%%DATADIR%%/resources/tango/16x16/bookmark.png
+%%DATADIR%%/resources/tango/16x16/cancel.png
+%%DATADIR%%/resources/tango/16x16/compare.png
+%%DATADIR%%/resources/tango/16x16/disconnect.png
+%%DATADIR%%/resources/tango/16x16/download.png
+%%DATADIR%%/resources/tango/16x16/downloadadd.png
+%%DATADIR%%/resources/tango/16x16/file.png
+%%DATADIR%%/resources/tango/16x16/filter.png
+%%DATADIR%%/resources/tango/16x16/find.png
+%%DATADIR%%/resources/tango/16x16/folder.png
+%%DATADIR%%/resources/tango/16x16/folderclosed.png
+%%DATADIR%%/resources/tango/16x16/localtreeview.png
+%%DATADIR%%/resources/tango/16x16/lock.png
+%%DATADIR%%/resources/tango/16x16/logview.png
+%%DATADIR%%/resources/tango/16x16/processqueue.png
+%%DATADIR%%/resources/tango/16x16/queueview.png
+%%DATADIR%%/resources/tango/16x16/reconnect.png
+%%DATADIR%%/resources/tango/16x16/refresh.png
+%%DATADIR%%/resources/tango/16x16/remotetreeview.png
+%%DATADIR%%/resources/tango/16x16/server.png
+%%DATADIR%%/resources/tango/16x16/sitemanager.png
+%%DATADIR%%/resources/tango/16x16/synchronize.png
+%%DATADIR%%/resources/tango/16x16/unknown.png
+%%DATADIR%%/resources/tango/16x16/upload.png
+%%DATADIR%%/resources/tango/16x16/uploadadd.png
+%%DATADIR%%/resources/tango/32x32/ascii.png
+%%DATADIR%%/resources/tango/32x32/auto.png
+%%DATADIR%%/resources/tango/32x32/binary.png
+%%DATADIR%%/resources/tango/32x32/bookmark.png
+%%DATADIR%%/resources/tango/32x32/cancel.png
+%%DATADIR%%/resources/tango/32x32/compare.png
+%%DATADIR%%/resources/tango/32x32/disconnect.png
+%%DATADIR%%/resources/tango/32x32/download.png
+%%DATADIR%%/resources/tango/32x32/downloadadd.png
+%%DATADIR%%/resources/tango/32x32/file.png
+%%DATADIR%%/resources/tango/32x32/filter.png
+%%DATADIR%%/resources/tango/32x32/find.png
+%%DATADIR%%/resources/tango/32x32/folder.png
+%%DATADIR%%/resources/tango/32x32/folderclosed.png
+%%DATADIR%%/resources/tango/32x32/localtreeview.png
+%%DATADIR%%/resources/tango/32x32/lock.png
+%%DATADIR%%/resources/tango/32x32/logview.png
+%%DATADIR%%/resources/tango/32x32/processqueue.png
+%%DATADIR%%/resources/tango/32x32/queueview.png
+%%DATADIR%%/resources/tango/32x32/reconnect.png
+%%DATADIR%%/resources/tango/32x32/refresh.png
+%%DATADIR%%/resources/tango/32x32/remotetreeview.png
+%%DATADIR%%/resources/tango/32x32/server.png
+%%DATADIR%%/resources/tango/32x32/sitemanager.png
+%%DATADIR%%/resources/tango/32x32/synchronize.png
+%%DATADIR%%/resources/tango/32x32/unknown.png
+%%DATADIR%%/resources/tango/32x32/upload.png
+%%DATADIR%%/resources/tango/32x32/uploadadd.png
+%%DATADIR%%/resources/tango/48x48/ascii.png
+%%DATADIR%%/resources/tango/48x48/auto.png
+%%DATADIR%%/resources/tango/48x48/binary.png
+%%DATADIR%%/resources/tango/48x48/bookmark.png
+%%DATADIR%%/resources/tango/48x48/cancel.png
+%%DATADIR%%/resources/tango/48x48/compare.png
+%%DATADIR%%/resources/tango/48x48/disconnect.png
+%%DATADIR%%/resources/tango/48x48/download.png
+%%DATADIR%%/resources/tango/48x48/downloadadd.png
+%%DATADIR%%/resources/tango/48x48/file.png
+%%DATADIR%%/resources/tango/48x48/filter.png
+%%DATADIR%%/resources/tango/48x48/find.png
+%%DATADIR%%/resources/tango/48x48/folder.png
+%%DATADIR%%/resources/tango/48x48/folderclosed.png
+%%DATADIR%%/resources/tango/48x48/localtreeview.png
+%%DATADIR%%/resources/tango/48x48/lock.png
+%%DATADIR%%/resources/tango/48x48/logview.png
+%%DATADIR%%/resources/tango/48x48/processqueue.png
+%%DATADIR%%/resources/tango/48x48/queueview.png
+%%DATADIR%%/resources/tango/48x48/reconnect.png
+%%DATADIR%%/resources/tango/48x48/refresh.png
+%%DATADIR%%/resources/tango/48x48/remotetreeview.png
+%%DATADIR%%/resources/tango/48x48/server.png
+%%DATADIR%%/resources/tango/48x48/sitemanager.png
+%%DATADIR%%/resources/tango/48x48/synchronize.png
+%%DATADIR%%/resources/tango/48x48/unknown.png
+%%DATADIR%%/resources/tango/48x48/upload.png
+%%DATADIR%%/resources/tango/48x48/uploadadd.png
+%%DATADIR%%/resources/tango/theme.xml
%%DATADIR%%/resources/48x48/filezilla.png
%%DATADIR%%/resources/48x48/speedlimits.png
%%DATADIR%%/resources/defaultfilters.xml
@@ -455,6 +541,7 @@ share/pixmaps/filezilla.png
share/icons/hicolor/16x16/apps/filezilla.png
share/icons/hicolor/32x32/apps/filezilla.png
share/icons/hicolor/48x48/apps/filezilla.png
+share/icons/hicolor/scalable/apps/filezilla.svg
share/applications/filezilla.desktop
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
@@ -464,6 +551,10 @@ share/applications/filezilla.desktop
@dirrmtry share/icons/hicolor/16x16
@dirrmtry share/icons/hicolor
@dirrmtry share/applications
+@dirrm %%DATADIR%%/resources/tango/48x48
+@dirrm %%DATADIR%%/resources/tango/32x32
+@dirrm %%DATADIR%%/resources/tango/16x16
+@dirrm %%DATADIR%%/resources/tango
@dirrm %%DATADIR%%/resources/opencrystal/48x48
@dirrm %%DATADIR%%/resources/opencrystal/32x32
@dirrm %%DATADIR%%/resources/opencrystal/24x24
@@ -517,6 +608,8 @@ share/applications/filezilla.desktop
@dirrmtry share/locale/lv_LV
@dirrmtry share/locale/lt_LT/LC_MESSAGES
@dirrmtry share/locale/lt_LT
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
@dirrmtry share/locale/ko_KR/LC_MESSAGES
@dirrmtry share/locale/ko_KR
@dirrmtry share/locale/km_KH/LC_MESSAGES