aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING15
-rw-r--r--www/node/Makefile7
-rw-r--r--www/node/distinfo6
-rw-r--r--www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi4
-rw-r--r--www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc11
-rw-r--r--www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc12
-rw-r--r--www/node/files/patch-deps_v8_src_execution_simulator.h11
-rw-r--r--www/node/files/patch-deps_v8_src_libsampler_sampler.cc4
-rw-r--r--www/node/files/patch-node.gypi4
-rw-r--r--www/node/pkg-plist8
10 files changed, 33 insertions, 49 deletions
diff --git a/UPDATING b/UPDATING
index 7ea1d0cd9955..b28b76d821ff 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,21 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20201029:
+ AFFECTS: users of www/node
+ AUTHOR: bhughes@FreeBSD.org
+
+ The www/node port has been updated to Node.js v15.0.0, the latest
+ upstream release. A new port, www/node14, has been created for the
+ v14.x LTS branch. Users wanting to stay on v14.x can replace www/node
+ with www/node14 with one of the following commands:
+
+ # pkg install www/node14
+ or
+ # portmaster -o www/node14 www/node
+ or
+ # portupgrade -o www/node14 www/node
+
20201026:
AFFECTS: users of emulators/qemu
AUTHOR: bofh@FreeBSD.org
diff --git a/www/node/Makefile b/www/node/Makefile
index 3193e84c3fee..305dca7aee19 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -2,7 +2,7 @@
PORTNAME= node
DISTVERSIONPREFIX= v
-DISTVERSION= 14.14.0
+DISTVERSION= 15.0.0
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${DISTVERSION}/
@@ -13,7 +13,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_SSL= libressl libressl-devel
-BROKEN_SSL_REASON= Node.js 14.x requires OpenSSL 1.1.x or the BUNDLED_SSL option enabled
+BROKEN_SSL_REASON= Node.js 15.x requires OpenSSL 1.1.x or the BUNDLED_SSL option enabled
ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc64 powerpc64le
OPTIONS_DEFINE= BUNDLED_SSL DOCS NLS DTRACE
@@ -53,7 +53,6 @@ CONFLICTS_INSTALL= node10-[0-9]* node12-[0-9]* node14-[0-9]*
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--without-npm \
--shared-brotli \
- --shared-cares \
--shared-libuv \
--shared-nghttp2 \
--shared-zlib
@@ -70,12 +69,10 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
BUILD_DEPENDS+= brotli>=1.0.9,1:archivers/brotli \
- c-ares>=1.16.1:dns/c-ares \
libuv>=1.40.0:devel/libuv \
libnghttp2>=1.41.0:www/libnghttp2 \
objdump:devel/binutils
LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
- libcares.so:dns/c-ares\
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2
diff --git a/www/node/distinfo b/www/node/distinfo
index bdbcd60bddd5..6fc790c264f3 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1603133528
-SHA256 (node-v14.14.0.tar.gz) = afb0b401d62d9fcfc68258f50d0bf042998d349ce9c1d7a2d45dd87870b3aab7
-SIZE (node-v14.14.0.tar.gz) = 63133260
+TIMESTAMP = 1603878735
+SHA256 (node-v15.0.0.tar.gz) = 72f6234594877ab212c43a76f2f5b05d409d7c025e0eb36d675d9acfd0d3f2d8
+SIZE (node-v15.0.0.tar.gz) = 63076769
diff --git a/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi b/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
index 552266b703f0..ed61fb35e52c 100644
--- a/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
+++ b/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
@@ -1,6 +1,6 @@
---- deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi.orig 2019-08-06 20:46:23 UTC
+--- deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi.orig 2020-10-20 11:49:49 UTC
+++ deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi
-@@ -696,7 +696,7 @@
+@@ -698,7 +698,7 @@
'-Wall -O3 -fomit-frame-pointer',
],
'openssl_ex_libs_linux-elf': [
diff --git a/www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc b/www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
deleted file mode 100644
index b8985dcef76d..000000000000
--- a/www/node/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- deps/v8/src/compiler/backend/instruction-selector.cc.orig 2020-07-20 22:18:45 UTC
-+++ deps/v8/src/compiler/backend/instruction-selector.cc
-@@ -2808,7 +2808,7 @@ void InstructionSelector::VisitCall(Node* node, BasicB
- switch (call_descriptor->kind()) {
- case CallDescriptor::kCallAddress: {
- int misc_field = static_cast<int>(call_descriptor->ParameterCount());
--#if defined(_AIX)
-+#if defined(_AIX) || (V8_TARGET_ARCH_PPC_BE && (!defined(_CALL_ELF) || _CALL_ELF == 1))
- // Highest misc_field bit is used on AIX to indicate if a CFunction call
- // has function descriptor or not.
- if (!call_descriptor->NoFunctionDescriptor()) {
diff --git a/www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc b/www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc
deleted file mode 100644
index a69dfeecd00f..000000000000
--- a/www/node/files/patch-deps_v8_src_compiler_backend_ppc_code-generator-ppc.cc
+++ /dev/null
@@ -1,12 +0,0 @@
---- deps/v8/src/compiler/backend/ppc/code-generator-ppc.cc.orig 2020-07-20 22:18:45 UTC
-+++ deps/v8/src/compiler/backend/ppc/code-generator-ppc.cc
-@@ -1038,8 +1038,7 @@ CodeGenerator::CodeGenResult CodeGenerator::AssembleAr
- bool isWasmCapiFunction =
- linkage()->GetIncomingDescriptor()->IsWasmCapiFunction();
- int offset = (FLAG_enable_embedded_constant_pool ? 20 : 23) * kInstrSize;
--
--#if defined(_AIX)
-+#if defined(_AIX) || (V8_TARGET_ARCH_PPC_BE && (!defined(_CALL_ELF) || _CALL_ELF == 1))
- // AIX/PPC64BE Linux uses a function descriptor
- int kNumParametersMask = kHasFunctionDescriptorBitMask - 1;
- num_parameters = kNumParametersMask & misc_field;
diff --git a/www/node/files/patch-deps_v8_src_execution_simulator.h b/www/node/files/patch-deps_v8_src_execution_simulator.h
deleted file mode 100644
index 2523115279b1..000000000000
--- a/www/node/files/patch-deps_v8_src_execution_simulator.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- deps/v8/src/execution/simulator.h.orig 2019-11-21 21:14:01 UTC
-+++ deps/v8/src/execution/simulator.h
-@@ -128,7 +128,7 @@ class GeneratedCode {
- #if defined(V8_TARGET_OS_WIN) && !defined(V8_OS_WIN)
- FATAL("Generated code execution not possible during cross-compilation.");
- #endif // defined(V8_TARGET_OS_WIN) && !defined(V8_OS_WIN)
--#if V8_OS_AIX
-+#if V8_OS_AIX || (V8_TARGET_ARCH_PPC_BE && (!defined(_CALL_ELF) || _CALL_ELF == 1))
- // AIX ABI requires function descriptors (FD). Artificially create a pseudo
- // FD to ensure correct dispatch to generated code. The 'volatile'
- // declaration is required to avoid the compiler from not observing the
diff --git a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
index 74fce64be593..2839eafa428d 100644
--- a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
+++ b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/libsampler/sampler.cc.orig 2020-06-30 17:49:17 UTC
+--- deps/v8/src/libsampler/sampler.cc.orig 2020-10-20 11:49:50 UTC
+++ deps/v8/src/libsampler/sampler.cc
-@@ -482,6 +482,10 @@ void SignalHandler::FillRegisterState(void* context, R
+@@ -489,6 +489,10 @@ void SignalHandler::FillRegisterState(void* context, R
state->pc = reinterpret_cast<void*>(mcontext.__gregs[_REG_PC]);
state->sp = reinterpret_cast<void*>(mcontext.__gregs[_REG_SP]);
state->fp = reinterpret_cast<void*>(mcontext.__gregs[_REG_FP]);
diff --git a/www/node/files/patch-node.gypi b/www/node/files/patch-node.gypi
index 57871fff3e10..79316657cfc9 100644
--- a/www/node/files/patch-node.gypi
+++ b/www/node/files/patch-node.gypi
@@ -1,6 +1,6 @@
---- node.gypi.orig 2020-03-05 00:41:47 UTC
+--- node.gypi.orig 2020-10-20 11:49:51 UTC
+++ node.gypi
-@@ -322,6 +322,9 @@
+@@ -340,6 +340,9 @@
['openssl_fips != "" or openssl_is_fips=="true"', {
'defines': [ 'NODE_FIPS_MODE' ],
}],
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index 99dd57c03721..5e992a3f1c4a 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -4,10 +4,12 @@ include/node/config.gypi
include/node/cppgc/allocation.h
include/node/cppgc/common.h
include/node/cppgc/custom-space.h
+include/node/cppgc/default-platform.h
include/node/cppgc/garbage-collected.h
include/node/cppgc/heap.h
-include/node/cppgc/internal/accessors.h
include/node/cppgc/internal/api-constants.h
+include/node/cppgc/internal/atomic-entry-flag.h
+include/node/cppgc/internal/caged-heap-local-data.h
include/node/cppgc/internal/compiler-specific.h
include/node/cppgc/internal/finalizer-trait.h
include/node/cppgc/internal/gc-info.h
@@ -15,6 +17,8 @@ include/node/cppgc/internal/logging.h
include/node/cppgc/internal/persistent-node.h
include/node/cppgc/internal/pointer-policies.h
include/node/cppgc/internal/prefinalizer-handler.h
+include/node/cppgc/internal/process-heap.h
+include/node/cppgc/internal/write-barrier.h
include/node/cppgc/liveness-broker.h
include/node/cppgc/macros.h
include/node/cppgc/member.h
@@ -483,8 +487,10 @@ include/node/node_version.h
%%BUNDLED_SSL%%include/node/openssl/x509err.h
%%BUNDLED_SSL%%include/node/openssl/x509v3.h
%%BUNDLED_SSL%%include/node/openssl/x509v3err.h
+include/node/v8-cppgc.h
include/node/v8-fast-api-calls.h
include/node/v8-internal.h
+include/node/v8-metrics.h
include/node/v8-platform.h
include/node/v8-profiler.h
include/node/v8-util.h