aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/sherlock-lv2/Makefile27
-rw-r--r--audio/sherlock-lv2/distinfo3
-rw-r--r--audio/sherlock-lv2/files/patch-pugl_pugl_pugl__x11.c11
-rw-r--r--audio/sherlock-lv2/pkg-descr12
-rw-r--r--audio/sherlock-lv2/pkg-plist6
6 files changed, 60 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f45876e2608f..1ded492c758c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -715,6 +715,7 @@
SUBDIR += shairplay
SUBDIR += shairport
SUBDIR += shairport-sync
+ SUBDIR += sherlock-lv2
SUBDIR += shntool
SUBDIR += shorten
SUBDIR += shout
diff --git a/audio/sherlock-lv2/Makefile b/audio/sherlock-lv2/Makefile
new file mode 100644
index 000000000000..8f0b1ee3eab9
--- /dev/null
+++ b/audio/sherlock-lv2/Makefile
@@ -0,0 +1,27 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= sherlock
+PORTVERSION= 0.14.0
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Investigative LV2 plugin bundle
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libserd-0.so:devel/serd \
+ libsord-0.so:devel/sord \
+ libsratom-0.so:audio/sratom
+
+USES= cmake pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= OpenMusicKontrollers
+GH_PROJECT= sherlock.lv2
+USE_XORG= x11 xext
+USE_GL= gl glu
+
+.include <bsd.port.mk>
diff --git a/audio/sherlock-lv2/distinfo b/audio/sherlock-lv2/distinfo
new file mode 100644
index 000000000000..ffbee44721d4
--- /dev/null
+++ b/audio/sherlock-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501832143
+SHA256 (OpenMusicKontrollers-sherlock.lv2-0.14.0_GH0.tar.gz) = 7130906e2fcb6f7c678b782e2c94ee52c85ecb98377bb438e479d818534d64a3
+SIZE (OpenMusicKontrollers-sherlock.lv2-0.14.0_GH0.tar.gz) = 1756933
diff --git a/audio/sherlock-lv2/files/patch-pugl_pugl_pugl__x11.c b/audio/sherlock-lv2/files/patch-pugl_pugl_pugl__x11.c
new file mode 100644
index 000000000000..3bd0244644a3
--- /dev/null
+++ b/audio/sherlock-lv2/files/patch-pugl_pugl_pugl__x11.c
@@ -0,0 +1,11 @@
+--- pugl/pugl/pugl_x11.c.orig 2017-08-04 07:37:10 UTC
++++ pugl/pugl/pugl_x11.c
+@@ -648,7 +648,7 @@ puglPasteFromClipboard(PuglView* view, s
+ if( (xevent.xselection.selection == impl->clipboard)
+ && (xevent.xselection.target == impl->utf8_string)
+ && (xevent.xselection.property == XA_PRIMARY) ) {
+- ulong nitems, rem;
++ unsigned long nitems, rem;
+ int format;
+ uint8_t* data;
+ Atom type;
diff --git a/audio/sherlock-lv2/pkg-descr b/audio/sherlock-lv2/pkg-descr
new file mode 100644
index 000000000000..b4a1866a6d2c
--- /dev/null
+++ b/audio/sherlock-lv2/pkg-descr
@@ -0,0 +1,12 @@
+A set of utilities to inspect other plugins:
+* The Atom Inspector is meant as a monitor/debug tool for LV2 plugin and
+ host authors. It captures all Atom events sent to its event input port
+ and presents them on its user interface for convenient nested browsing.
+* The MIDI Inspector is meant as a monitor/debug tool for LV2 plugin and
+ host authors. It captures all MIDI events sent to its event input port
+ and presents them on its user interface for convenient nested browsing.
+* The OSC Inspector is meant as a monitor/debug tool for LV2 plugin and
+ host authors. It captures all OSC events sent to its event input port
+ and presents them on its user interface for convenient nested browsing.
+
+WWW: https://open-music-kontrollers.ch/lv2/sherlock/
diff --git a/audio/sherlock-lv2/pkg-plist b/audio/sherlock-lv2/pkg-plist
new file mode 100644
index 000000000000..f8ea801d6a86
--- /dev/null
+++ b/audio/sherlock-lv2/pkg-plist
@@ -0,0 +1,6 @@
+lib/lv2/sherlock.lv2/Cousine-Regular.ttf
+lib/lv2/sherlock.lv2/manifest.ttl
+lib/lv2/sherlock.lv2/sherlock.so
+lib/lv2/sherlock.lv2/sherlock.ttl
+lib/lv2/sherlock.lv2/sherlock_nk.so
+lib/lv2/sherlock.lv2/sherlock_ui.ttl