aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/py-spvcm/Makefile27
-rw-r--r--math/py-spvcm/distinfo3
-rw-r--r--math/py-spvcm/pkg-descr8
4 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index ee8ffe942c88..5e3dc20f2c1b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -848,6 +848,7 @@
SUBDIR += py-splot
SUBDIR += py-spot
SUBDIR += py-spreg
+ SUBDIR += py-spvcm
SUBDIR += py-ssm
SUBDIR += py-statsmodels
SUBDIR += py-statsmodels010
diff --git a/math/py-spvcm/Makefile b/math/py-spvcm/Makefile
new file mode 100644
index 000000000000..5f3e4e3f065d
--- /dev/null
+++ b/math/py-spvcm/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spvcm
+PORTVERSION= 0.3.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fit spatial multilevel models and diagnose convergence
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libpysal>=0:science/py-libpysal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}seaborn>=0:math/py-seaborn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spreg>=0:math/py-spreg@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-spvcm/distinfo b/math/py-spvcm/distinfo
new file mode 100644
index 000000000000..6c43139a755b
--- /dev/null
+++ b/math/py-spvcm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609598753
+SHA256 (spvcm-0.3.0.tar.gz) = ce331bd5d6bcb64a07c4393093f3978763cfc8764ad0737e1866f3905e6cceae
+SIZE (spvcm-0.3.0.tar.gz) = 5724408
diff --git a/math/py-spvcm/pkg-descr b/math/py-spvcm/pkg-descr
new file mode 100644
index 000000000000..c216f65efce1
--- /dev/null
+++ b/math/py-spvcm/pkg-descr
@@ -0,0 +1,8 @@
+Gibbs sampling for spatially-correlated variance-components
+
+This is a package to estimate spatially-correlated variance components
+models/varying intercept models. In addition to a general toolkit to conduct
+Gibbs sampling in Python, the package also provides an interface to PyMC3 and
+CODA.
+
+WWW: https://github.com/pysal/spvcm