aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/p5-BerkeleyDB/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/databases/p5-BerkeleyDB/Makefile b/databases/p5-BerkeleyDB/Makefile
index d0ca4b2bebd9..01793893e451 100644
--- a/databases/p5-BerkeleyDB/Makefile
+++ b/databases/p5-BerkeleyDB/Makefile
@@ -20,9 +20,13 @@ LIB_DEPENDS= db3.2:${PORTSDIR}/databases/db3
PERL_CONFIGURE= yes
ALL_TARGET= all test
+MAN3= BerkeleyDB.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
post-patch:
${PERL} -pi -e 's|^(INCLUDE\s+= )./libraries/.*$$|$$1\$(PREFIX)/include/db3|g; \
s|^(LIB\s+= )./libraries/.*$$|$$1$(PREFIX)/lib|g' ${WRKSRC}/config.in
${PERL} -pi -e 's|^#DBNAME.*|DBNAME = -ldb3|' ${WRKSRC}/config.in
+ ${PERL} -pi -e '$$_="" if /MAN3PODS/' ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>