aboutsummaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES20
1 files changed, 20 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index e70274fd0e40..c151cc3d5a04 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,26 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20150928:
+AUTHOR: amdmi3@FreeBSD.org
+
+ Implemented complete support for test target.
+
+ You can now `make test' on any port to run test sequence, no-op by default.
+ If a port defines TEST_TARGET, it'll run sub-make with specified target,
+ usually `check' or `test' if upstream supports that. The port may also
+ define custom do-test target, as well as usual satellite targets:
+
+ {pre,do,post}-test, {pre,do,post}-test-OPT, {pre,do,post}-test-OPT-off
+
+ `make test' builds and stages port first, so test may use both WRKDIR and
+ STAGEDIR, and both BUILD and RUN depends are available for test target.
+ Additionally, TEST_DEPENDS is now properly supported and may be used to
+ define additional depends specifically for testing.
+
+ Framework may define default tests for specific cases. For instance,
+ perl5.mk and cran.mk provide default test target on their own.
+
20150926:
AUTHOR: bapt@FreeBSD.org