aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/cran.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/cran.mk')
-rw-r--r--Mk/Uses/cran.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/Mk/Uses/cran.mk b/Mk/Uses/cran.mk
index 1824ca6f0ec2..b63d76c73489 100644
--- a/Mk/Uses/cran.mk
+++ b/Mk/Uses/cran.mk
@@ -4,9 +4,10 @@
#
# Feature: cran
# Usage: USES=cran or USES=cran:ARGS
-# Valid ARGS: auto-plist
+# Valid ARGS: auto-plist, compiles
#
-# auto-plist The pkg-plist can be automatically compiled
+# auto-plist The pkg-plist is to be automatically generated
+# compiles The port has code that needs to be compiled
#
# MAINTAINER= wen@FreeBSD.org
@@ -76,4 +77,8 @@ cran-auto-plist:
${SED} -E -e 's,^${STAGEDIR}${PREFIX}/?,,' >> ${TMPPLIST}
.endif
+.if ${cran_ARGS:Mcompiles}
+.include "${PORTSDIR}/math/R/compiler.mk"
+.endif
+
.endif #_INCLUDE_USES_CRAN_MK