aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index ec8804fa3c09..037e711c62df 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -110,15 +110,14 @@ LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME} -L${_GCC_RUNTIME}
CFLAGS:= ${CFLAGS:N-mretpoline}
CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
-. if defined(_GCC_PORT)
BUILD_DEPENDS+= ${CC}:lang/${_GCC_PORT}
-. if defined(_USE_GCC_RUN_DEPENDS)
+. if defined(_USE_GCC_RUN_DEPENDS)
RUN_DEPENDS+= ${CC}:lang/${_GCC_PORT}
-. endif
+. endif
+
# GCC ports already depend on binutils; make sure whatever we build
# leverages this as well.
USE_BINUTILS= yes
-. endif
.endif # defined(_USE_GCC) && !defined(FORCE_BASE_CC_FOR_TESTING)