aboutsummaryrefslogtreecommitdiff
path: root/accessibility/at-spi2-atk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/at-spi2-atk/Makefile')
-rw-r--r--accessibility/at-spi2-atk/Makefile36
1 files changed, 18 insertions, 18 deletions
diff --git a/accessibility/at-spi2-atk/Makefile b/accessibility/at-spi2-atk/Makefile
index fb67fdb8750b..607125e93a4e 100644
--- a/accessibility/at-spi2-atk/Makefile
+++ b/accessibility/at-spi2-atk/Makefile
@@ -1,34 +1,34 @@
-# New ports collection makefile for: at-spi
-# Date Created: 12 April 2002
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/accessibility/at-spi2-atk/Makefile,v 1.16 2010/11/16 11:53:13 kwm Exp $
-#
+# $MCom: ports/accessibility/at-spi2-atk/Makefile,v 1.38 2012/12/16 22:36:25 kwm Exp $
PORTNAME= at-spi2-atk
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTVERSION= 2.6.2
CATEGORIES= accessibility x11-toolkits
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Assisted Technology Provider module for GTK+
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-RUN_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:${PORTSDIR}/accessibility/at-spi2-core
+LICENSE= LGPL21
-LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-USE_BZIP2= yes
-USE_GETTEXT= yes
+BUILD_DEPENDS= at-spi2-core>=2.1.4:${PORTSDIR}/accessibility/at-spi2-core
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
+RUN_DEPENDS= at-spi2-core>=2.1.4:${PORTSDIR}/accessibility/at-spi2-core
+
+CONFLICTS= at-spi-1.[0-9]*
+PORTSCOUT= limitw:1,even
+
+USE_XZ= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomehier intlhack gconf2 libxml2
+USE_GNOME= gnomehack gnomehier intlhack glib20 atk
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-static
+USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-GCONF_SCHEMAS= at-spi2.schemas
+CONFIGURE_ARGS= --enable-p2p
+GLIB_SCHEMAS= org.a11y.atspi.gschema.xml
.include <bsd.port.mk>