aboutsummaryrefslogtreecommitdiff
path: root/archivers/engrampa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/engrampa/Makefile')
-rw-r--r--archivers/engrampa/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/archivers/engrampa/Makefile b/archivers/engrampa/Makefile
new file mode 100644
index 000000000000..196518a18b70
--- /dev/null
+++ b/archivers/engrampa/Makefile
@@ -0,0 +1,40 @@
+# Created by: Anders Nordby <anders@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= engrampa
+PORTVERSION= 1.8.0
+CATEGORIES= archivers mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Archive manager for zip files, tar, etc
+
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+RUN_DEPENDS= ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
+
+PORTSCOUT= limitw:1,even
+
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
+ tar:xz
+USE_MATE= caja
+USE_XORG= sm
+USE_GNOME= glib20 gnomehier gtk20 intlhack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-packagekit \
+ --with-gtk=2.0
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+GLIB_SCHEMAS= org.mate.engrampa.gschema.xml
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/fr-command-tar.c \
+ ${WRKSRC}/src/fr-command-zip.c
+
+.include <bsd.port.mk>