aboutsummaryrefslogtreecommitdiff
path: root/archivers/hs-zlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/hs-zlib/Makefile')
-rw-r--r--archivers/hs-zlib/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/archivers/hs-zlib/Makefile b/archivers/hs-zlib/Makefile
new file mode 100644
index 000000000000..aec9622e197b
--- /dev/null
+++ b/archivers/hs-zlib/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: zlib
+# Date created: November 2, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= zlib
+PORTVERSION= 0.5.0.0
+CATEGORIES= archivers haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://kerneled.org/tmp/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Pure Haskell interface to the C zlib library
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.hs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>