aboutsummaryrefslogtreecommitdiff
path: root/archivers/xdms/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/xdms/Makefile')
-rw-r--r--archivers/xdms/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/archivers/xdms/Makefile b/archivers/xdms/Makefile
index 2c419eb8b191..b26726dc1a72 100644
--- a/archivers/xdms/Makefile
+++ b/archivers/xdms/Makefile
@@ -9,7 +9,10 @@ MASTER_SITES= http://zakalwe.fi/~shd/foss/xdms/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for decompressing Amiga DMS files
-OPTIONS_DEFINE= DOCS
+LICENSE= PD
+LICENSE_NAME= Public Domain
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= tar:bzip2
HAS_CONFIGURE= yes
@@ -21,14 +24,16 @@ USE_CSTD= gnu89
PORTDOCS= xdms.txt
PLIST_FILES= bin/xdms
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} "s@-O2 -Wall@$${CFLAGS} -Wall@g" ${WRKSRC}/src/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xdms ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/xdms.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>