aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
Diffstat (limited to 'archivers')
-rw-r--r--archivers/py-cramjam/Makefile4
-rw-r--r--archivers/py-cramjam/files/patch-pyproject.toml9
2 files changed, 11 insertions, 2 deletions
diff --git a/archivers/py-cramjam/Makefile b/archivers/py-cramjam/Makefile
index 2f0b8769373a..f7c024eb185e 100644
--- a/archivers/py-cramjam/Makefile
+++ b/archivers/py-cramjam/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cramjam
PORTVERSION= 2.6.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ WWW= https://github.com/milesgranger/pyrus-cramjam
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}maturin>=0.13<0.14:devel/py-maturin@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}maturin>=0.13:devel/py-maturin@${PY_FLAVOR}
USES= cargo python:3.7+
USE_PYTHON= autoplist concurrent pep517
diff --git a/archivers/py-cramjam/files/patch-pyproject.toml b/archivers/py-cramjam/files/patch-pyproject.toml
new file mode 100644
index 000000000000..ab0696491d41
--- /dev/null
+++ b/archivers/py-cramjam/files/patch-pyproject.toml
@@ -0,0 +1,9 @@
+--- pyproject.toml.orig 2022-11-09 14:23:00 UTC
++++ pyproject.toml
+@@ -9,5 +9,5 @@ documentation = "https://docs.rs/cramjam/latest/cramja
+ repository = "https://github.com/milesgranger/pyrus-cramjam"
+
+ [build-system]
+-requires = ["maturin>=0.13,<0.14"]
++requires = ["maturin>=0.13"]
+ build-backend = "maturin"