aboutsummaryrefslogtreecommitdiff
path: root/astro/opencpn/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'astro/opencpn/files/patch-CMakeLists.txt')
-rw-r--r--astro/opencpn/files/patch-CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/astro/opencpn/files/patch-CMakeLists.txt b/astro/opencpn/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..2e43f752546d
--- /dev/null
+++ b/astro/opencpn/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2016-06-25 12:26:20 UTC
++++ CMakeLists.txt
+@@ -1769,7 +1769,7 @@ ENDIF(UNIX)
+ # Certain older Cmake FindGTK2 modules ( e.g. cmake-2.8.0-2) do not yield all of the required link libraries
+ # So, add them manually. These declarations may be redundant in some architectures, but do no harm.
+ IF(UNIX)
+-TARGET_LINK_LIBRARIES( ${PACKAGE_NAME} dl )
++TARGET_LINK_LIBRARIES( ${PACKAGE_NAME} execinfo )
+ ENDIF(UNIX)
+
+ IF(QT_LINUX)