aboutsummaryrefslogtreecommitdiff
path: root/astro/py-pyfits/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/py-pyfits/Makefile')
-rw-r--r--astro/py-pyfits/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/astro/py-pyfits/Makefile b/astro/py-pyfits/Makefile
new file mode 100644
index 000000000000..0a68dfd7bc29
--- /dev/null
+++ b/astro/py-pyfits/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: pyfits
+# Date created: 2008-10-28
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyfits
+PORTVERSION= 1.3
+CATEGORIES= astro python
+MASTER_SITES= http://www.stsci.edu/resources/software_hardware/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python Interface to FITS Formatted Files
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:${PORTSDIR}/math/py-numpy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>