aboutsummaryrefslogtreecommitdiff
path: root/audio/extace/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/extace/Makefile')
-rw-r--r--audio/extace/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/audio/extace/Makefile b/audio/extace/Makefile
index 7a4d432c5ff1..5543a96963dd 100644
--- a/audio/extace/Makefile
+++ b/audio/extace/Makefile
@@ -6,19 +6,16 @@
#
PORTNAME= extace
-PORTVERSION= 1.9.6
-PORTREVISION= 1
+PORTVERSION= 1.9.9
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An Audio Visualization plugin for the X Window System
LIB_DEPENDS= fftw3.4:${PORTSDIR}/math/fftw3
-USE_XLIB= yes
-USE_GNOME= esound imlib gnomehack gnometarget gnomeprefix
+USE_GNOME= esound gnomehack gnomehier gnometarget gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -27,7 +24,7 @@ PLIST_FILES= bin/extace \
share/gnome/apps/Multimedia/extace.desktop
post-patch:
- @${REINPLACE_CMD} -e 's|-O2 |$$CFLAGS|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|^LIBS =|#LIBS =|g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>