aboutsummaryrefslogtreecommitdiff
path: root/audio/flac/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/flac/Makefile')
-rw-r--r--audio/flac/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index ca235de0b215..8a16a4325046 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -10,11 +10,11 @@ MASTER_SITES= http://downloads.xiph.org/releases/flac/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Free lossless audio codec
-LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg
USES= pathfix pkgconfig
-NO_STAGE= yes
USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sse \
@@ -26,24 +26,11 @@ CONFIGURE_ARGS= --enable-sse \
OPTIONS_DEFINE= DOCS ICONV
OPTIONS_DEFAULT=ICONV
-.include <bsd.port.options.mk>
+ICONV_USES= iconv
+ICONV_CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include
+ICONV_LDFLAGS= -L${LOCALBASE}/lib
-.if ${PORT_OPTIONS:MICONV}
-USES+= iconv
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-MAKE_ENV+= DOC=doc
-.else
-MAKE_ENV+= DOC=""
-.endif
-
-USE_LDCONFIG= yes
-MAN1= flac.1 metaflac.1
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
@@ -59,4 +46,4 @@ post-build:
regression-test: build
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>