aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-shout/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gmpc-shout/Makefile')
-rw-r--r--audio/gmpc-shout/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/gmpc-shout/Makefile b/audio/gmpc-shout/Makefile
new file mode 100644
index 000000000000..7037dd8f2af2
--- /dev/null
+++ b/audio/gmpc-shout/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gmpc-shout
+# Date created: March 27 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-shout
+PORTVERSION= 0.15.5.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION:C/\.0$//}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Shoutcast stream for gmpc
+
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+LIB_DEPENDS+= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XORG= x11
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>