aboutsummaryrefslogtreecommitdiff
path: root/audio/grip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/grip/Makefile')
-rw-r--r--audio/grip/Makefile33
1 files changed, 16 insertions, 17 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 5cfda94f626c..cb7b1e78936a 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -1,10 +1,9 @@
# Created by: kbyanc@posi.net
PORTNAME= grip
-PORTVERSION= 4.2.1
-PORTREVISION= 1
+DISTVERSION= 4.2.2
CATEGORIES= audio
-MASTER_SITES= SF/grip/${PORTVERSION}
+MASTER_SITES= SF/grip/${DISTVERSION}
MAINTAINER= freebsd-ports@jan0sch.de
COMMENT= GTK front-end to external cd rippers and audio encoders
@@ -17,16 +16,16 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libfreetype.so:print/freetype2 \
libid3.so:audio/id3lib
-USES= compiler:c++11-lang gmake gnome libtool localbase \
- pathfix pkgconfig xorg gnome
+USES= compiler:c++11-lang gmake gnome libtool localbase pathfix \
+ pkgconfig xorg
USE_GNOME= cairo gdkpixbuf2 gtk20
INSTALLS_ICONS= yes
USE_XORG= ice sm x11 xext
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-werror
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --disable-werror
-OPTIONS_DEFINE= CDPARANOIA CDDA2WAV LAME VORBIS FAAC FLAC NLS
+OPTIONS_DEFINE= CDDA2WAV CDPARANOIA FAAC FLAC LAME NLS VORBIS
OPTIONS_DEFAULT= CDPARANOIA FLAC VORBIS
.if !defined(PACKAGE_BUILDING)
@@ -35,19 +34,19 @@ OPTIONS_DEFAULT+= LAME
OPTIONS_SUB= yes
-CDPARANOIA_LIB_DEPENDS= libcdda_paranoia.so:audio/cdparanoia
+CDDA2WAV_RUN_DEPENDS= cdda2wav:sysutils/cdrtools
+CDPARANOIA_LIB_DEPENDS= libcdda_paranoia.so:audio/cdparanoia
CDPARANOIA_CONFIGURE_ENABLE= cdpar
-CDDA2WAV_RUN_DEPENDS= cdda2wav:sysutils/cdrtools
-FAAC_RUN_DEPENDS= faac:audio/faac
-FLAC_RUN_DEPENDS= flac:audio/flac
-LAME_RUN_DEPENDS= lame:audio/lame
-VORBIS_RUN_DEPENDS= ogg123:audio/vorbis-tools
-NLS_USES= gettext
+FAAC_RUN_DEPENDS= faac:audio/faac
+FLAC_RUN_DEPENDS= flac:audio/flac
+LAME_RUN_DEPENDS= lame:audio/lame
+VORBIS_RUN_DEPENDS= ogg123:audio/vorbis-tools
+NLS_USES= gettext
.if defined(WITH_CDROM_DEVICE)
-DEFAULT_CDROM_DEVICE=${WITH_CDROM_DEVICE}
+DEFAULT_CDROM_DEVICE= ${WITH_CDROM_DEVICE}
.else
-DEFAULT_CDROM_DEVICE=/dev/cd0
+DEFAULT_CDROM_DEVICE= /dev/cd0
.endif
.include <bsd.port.pre.mk>