aboutsummaryrefslogtreecommitdiff
path: root/audio/logitechmediaserver-superdatetime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/logitechmediaserver-superdatetime/Makefile')
-rw-r--r--audio/logitechmediaserver-superdatetime/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/audio/logitechmediaserver-superdatetime/Makefile b/audio/logitechmediaserver-superdatetime/Makefile
new file mode 100644
index 000000000000..c033a3410c79
--- /dev/null
+++ b/audio/logitechmediaserver-superdatetime/Makefile
@@ -0,0 +1,35 @@
+# Created by: Tim Bishop <tdb@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= superdatetime
+PORTVERSION= 5.9.16
+CATEGORIES= audio
+MASTER_SITES= GOOGLE_CODE
+PROJECTHOST= grebrown-projects
+PKGNAMEPREFIX= logitechmediaserver-
+DISTNAME= SuperDateTime${PORTVERSION}
+DIST_SUBDIR= logitechmediaserver
+
+MAINTAINER= mark@tranquillussoftware.co.uk
+COMMENT= Logitech Media Server plugin to display weather conditions & forecasts
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+BROKEN= Unfetchable (google code has gone away)
+
+RUN_DEPENDS= ${LOCALBASE}/${SLIMDIR}/slimserver.pl:audio/logitechmediaserver
+
+USES= zip
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_ARCH= yes
+
+SLIMDIR?= share/logitechmediaserver
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${SLIMDIR}/Plugins/SuperDateTime
+ ${CP} -R ${WRKSRC}/SuperDateTime/* ${STAGEDIR}${PREFIX}/${SLIMDIR}/Plugins/SuperDateTime
+
+.include <bsd.port.mk>