aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3blaster/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mp3blaster/Makefile')
-rw-r--r--audio/mp3blaster/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index 9aa02e374e48..61b44c87d27f 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -2,23 +2,20 @@
# $FreeBSD$
PORTNAME= mp3blaster
-PORTVERSION= 3.2.5
-PORTREVISION= 6
+PORTVERSION= 3.2.6
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= novel@FreeBSD.org
COMMENT= MP3 console ncurses-based player
-USES= gmake ncurses
-GNU_CONFIGURE= yes
-WANT_GNOME= yes
-CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}"
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+USES= gmake localbase:ldflags ncurses
+GNU_CONFIGURE= yes
-OPTIONS_DEFINE= LIRC NAS SIDPLAY VORBIS DOCS ESOUND
+OPTIONS_DEFINE= DOCS ESOUND LIRC NAS SDL SIDPLAY VORBIS
OPTIONS_DEFAULT= SIDPLAY VORBIS
SIDPLAY_DESC= Sidplayer support
@@ -41,7 +38,7 @@ NAS_LIB_DEPENDS= libaudio.so:audio/nas
NAS_LDFLAGS= -laudio
ESOUND_CONFIGURE_WITH= esd
-ESOUND_GNOME= esound
+ESOUND_USE= GNOME=esound
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/share/mp3blaster/win2koi.tbl|${DATADIR}/charmap/win2koi.tbl|' \