aboutsummaryrefslogtreecommitdiff
path: root/audio/py-mpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/py-mpd/Makefile')
-rw-r--r--audio/py-mpd/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/audio/py-mpd/Makefile b/audio/py-mpd/Makefile
new file mode 100644
index 000000000000..209aa1a4be02
--- /dev/null
+++ b/audio/py-mpd/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-mpd
+# Date created: 2008-04-05
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpd
+PORTVERSION= 0.2.0
+#PORTREVISION= 0
+#PORTEPOCH= 0
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Python MPD client library
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python_mpd
+
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/commands.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>