aboutsummaryrefslogtreecommitdiff
path: root/audio/rtmidi/files/patch-configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rtmidi/files/patch-configure.ac')
-rw-r--r--audio/rtmidi/files/patch-configure.ac54
1 files changed, 14 insertions, 40 deletions
diff --git a/audio/rtmidi/files/patch-configure.ac b/audio/rtmidi/files/patch-configure.ac
index 7fbbf7c57f4c..bab89151aff7 100644
--- a/audio/rtmidi/files/patch-configure.ac
+++ b/audio/rtmidi/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2017-04-21 15:27:54 UTC
+--- configure.ac.orig 2017-09-01 00:10:07 UTC
+++ configure.ac
-@@ -65,7 +65,7 @@ AC_MSG_CHECKING(whether to compile debug
+@@ -72,7 +72,7 @@ AC_MSG_CHECKING(whether to compile debug
AC_ARG_ENABLE(debug,
[ --enable-debug = enable various debug output],
[AC_SUBST( cppflag, [-D__RTMIDI_DEBUG__] ) AC_SUBST( cxxflag, [-g] ) AC_SUBST( object_path, [Debug] ) AC_MSG_RESULT(yes)],
@@ -9,7 +9,7 @@
# Set paths if prefix is defined
if test "x$prefix" != "x" && test "x$prefix" != "xNONE"; then
-@@ -78,7 +78,7 @@ CPPFLAGS="$CPPFLAGS $cppflag"
+@@ -85,7 +85,7 @@ CPPFLAGS="$CPPFLAGS $cppflag"
# For debugging and optimization ... overwrite default because it has both -g and -O2
#CXXFLAGS="$CXXFLAGS $cxxflag"
@@ -18,41 +18,15 @@
# Check compiler and use -Wall if gnu.
if [test $GXX = "yes" ;] then
-@@ -105,25 +105,25 @@ AC_SUBST( api, [""] )
- AC_SUBST( req, [""] )
- AC_MSG_CHECKING(for MIDI API)
- case $host in
-- *-*-linux*)
-+ *-*-freebsd*)
- AC_ARG_WITH(jack, [ --with-jack = choose JACK server support (mac and linux only)], [
- api="$api -D__UNIX_JACK__"
- AC_MSG_RESULT(using JACK)
- AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))], )
-
- # Look for ALSA flag
-- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA sequencer API support (linux only)], [
-- api="$api -D__LINUX_ALSA__"
-- req="$req alsa"
-- AC_MSG_RESULT(using ALSA)
-- AC_CHECK_LIB(asound, snd_seq_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
-+ #AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA sequencer API support (linux only)], [
-+ # api="$api -D__LINUX_ALSA__"
-+ # req="$req alsa"
-+ # AC_MSG_RESULT(using ALSA)
-+ # AC_CHECK_LIB(asound, snd_seq_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
-
-- if [test "$api" == "";] then
-- AC_MSG_RESULT(using ALSA)
-- AC_SUBST( api, [-D__LINUX_ALSA__] )
-- req="$req alsa"
-- AC_CHECK_LIB(asound, snd_seq_open, , AC_MSG_ERROR(ALSA sequencer support requires the asound library!))
-- fi
-+ #if [test "$api" == "";] then
-+ # AC_MSG_RESULT(using ALSA)
-+ # AC_SUBST( api, [-D__LINUX_ALSA__] )
-+ # req="$req alsa"
-+ # AC_CHECK_LIB(asound, snd_seq_open, , AC_MSG_ERROR(ALSA sequencer support requires the asound library!))
-+ #fi
-
- # Checks for pthread library.
+@@ -139,6 +139,11 @@ case $host in
AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtMidi requires the pthread library!))
+ ;;
+
++ *-*-freebsd*)
++ # Checks for pthread library.
++ AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtMidi requires the pthread library!))
++ ;;
++
+ *-apple*)
+ # Look for Core flag
+ AC_ARG_WITH(core, [ --with-core = choose CoreMidi API support (mac only)])