aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl2_mixer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/sdl2_mixer/Makefile')
-rw-r--r--audio/sdl2_mixer/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/audio/sdl2_mixer/Makefile b/audio/sdl2_mixer/Makefile
index 4f1a92b85359..8217ada802fd 100644
--- a/audio/sdl2_mixer/Makefile
+++ b/audio/sdl2_mixer/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= sdl2_mixer
-PORTVERSION= 2.0.0
-PORTREVISION= 11
+PORTVERSION= 2.0.1
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL2_mixer-${PORTVERSION}
@@ -11,12 +10,11 @@ MAINTAINER= mva@FreeBSD.org
COMMENT= Sample multi-channel audio mixer library
LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
-USES= gmake pathfix pkgconfig libtool
+USES= gmake pathfix pkgconfig libtool localbase
USE_SDL= sdl2
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
OPTIONS_DEFINE= FLUIDSYNTH FLAC SMPEG
@@ -65,4 +63,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|"modplug.h"|"libmodplug/modplug.h"|' \
${WRKSRC}/dynamic_modplug.h ${WRKSRC}/music_modplug.h
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libSDL2_mixer.so
+
.include <bsd.port.mk>