aboutsummaryrefslogtreecommitdiff
path: root/audio/soundconverter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/soundconverter/Makefile')
-rw-r--r--audio/soundconverter/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/audio/soundconverter/Makefile b/audio/soundconverter/Makefile
new file mode 100644
index 000000000000..1319319a77bd
--- /dev/null
+++ b/audio/soundconverter/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: soundconverter
+# Date created: 04 September 2007
+# Whom: Jona Joachim <jaj@hcl-club.lu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= soundconverter
+PORTVERSION= 0.9.7
+CATEGORIES= audio python
+MASTER_SITES= BERLIOS
+#MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jaj@hcl-club.lu
+COMMENT= The sound conversion application for the GNOME environment
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gst-0.10/gst/__init__.py:${PORTSDIR}/multimedia/py-gstreamer
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+USE_GNOME= pygtk2 pygnome2
+
+MAKE_ENV= MAKE=${LOCALBASE}/bin/gmake
+
+INSTALLS_ICONS= yes
+MAN1= soundconverter.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@GMSGFMT@|${LOCALBASE}/bin/msgfmt|' ${WRKSRC}/po/Makefile.in.in
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/python|#!/usr/bin/env python|' ${WRKSRC}/src/soundconverter.py
+
+.include <bsd.port.mk>