aboutsummaryrefslogtreecommitdiff
path: root/audio/zynaddsubfx/files/patch-src_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'audio/zynaddsubfx/files/patch-src_CMakeLists.txt')
-rw-r--r--audio/zynaddsubfx/files/patch-src_CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/zynaddsubfx/files/patch-src_CMakeLists.txt b/audio/zynaddsubfx/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..edfe1fba4f13
--- /dev/null
+++ b/audio/zynaddsubfx/files/patch-src_CMakeLists.txt
@@ -0,0 +1,30 @@
+--- src/CMakeLists.txt.orig 2012-06-16 04:22:35 UTC
++++ src/CMakeLists.txt
+@@ -127,6 +127,13 @@ set (BuildOptionsDebug
+ # From here on, the setting variables have been prepared so concentrate
+ # on the actual compiling.
+
++if(PaEnable)
++ include_directories(${PORTAUDIO_INCLUDE_DIRS})
++ add_definitions(-DPORTAUDIO=1)
++ list(APPEND AUDIO_LIBRARIES ${PORTAUDIO_LIBRARIES})
++ list(APPEND AUDIO_LIBRARY_DIRS ${PORTAUDIO_LIBRARY_DIRS})
++endif()
++
+ if(AlsaEnable)
+ list(APPEND AUDIO_LIBRARIES ${ASOUND_LIBRARY})
+ list(APPEND AUDIO_LIBRARY_DIRS ${ASOUND_LIBRARY_DIRS})
+@@ -143,13 +150,6 @@ if(OssEnable)
+ add_definitions(-DOSS=1)
+ endif(OssEnable)
+
+-if(PaEnable)
+- include_directories(${PORTAUDIO_INCLUDE_DIR})
+- add_definitions(-DPORTAUDIO=1)
+- list(APPEND AUDIO_LIBRARIES ${PORTAUDIO_LIBRARIES})
+- list(APPEND AUDIO_LIBRARY_DIRS ${PORTAUDIO_LIBRARY_DIRS})
+-endif()
+-
+ if (CompileTests)
+ ENABLE_TESTING()
+ endif()