aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/baresip/Makefile99
-rw-r--r--audio/baresip/Makefile.depends28
-rw-r--r--audio/baresip/distinfo2
-rw-r--r--audio/baresip/files/patch-modules-v4l-v4l-c10
-rw-r--r--audio/baresip/pkg-descr5
6 files changed, 145 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index a44bc825ac16..dcadf4a34437 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -58,6 +58,7 @@
SUBDIR += autocd
SUBDIR += autotalent
SUBDIR += autozen
+ SUBDIR += baresip
SUBDIR += baudline
SUBDIR += beast
SUBDIR += bebocd
diff --git a/audio/baresip/Makefile b/audio/baresip/Makefile
new file mode 100644
index 000000000000..76856ed908da
--- /dev/null
+++ b/audio/baresip/Makefile
@@ -0,0 +1,99 @@
+# $FreeBSD$
+
+PORTNAME= baresip
+PORTVERSION= 0.4.0
+CATEGORIES= audio
+MASTER_SITES= http://www.creytiv.com/pub/
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Small SIP client
+
+BUILD_DEPENDS= ${LOCALBASE}/share/re/re.mk:${PORTSDIR}/audio/re \
+ ${LOCALBASE}/include/rem/rem.h:${PORTSDIR}/audio/rem
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_GMAKE= yes
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ilbc
+MAKE_ARGS= MOD_AUTODETECT=""
+PLIST_FILES= bin/baresip
+PORTDATA= *
+PORTDOCS= *
+
+#OPTIONS_NOT_YET_WORKING= ALSA BV32 G722_1 PLC PORTAUDIO V4L2
+OPTIONS_DEFINE= CELT CONS DOCS FFMPEG G711 G722 GSM GSTREAMER ILBC L16 OPUS \
+ OSS SDL SNDFILE SPEEX SRTP STDIO UUID V4L X11
+OPTIONS_DEFAULT=CONS G711 G722 L16
+
+BV32_DESC= BroadVoice32 Wideband Audio codec
+CONS_DESC= Console input driver
+G711_DESC= G.711 audio codec
+G722_DESC= G.722 audio codec
+G722_1_DESC= G.722.1 audio codec
+ILBC_DESC= iLBC audio codec
+L16_DESC= L16 audio codec
+OPUS_DESC= Opus audio codec
+PLC_DESC= Packet Loss Concealment
+SRTP_DESC= Secure RTP module
+STDIO_DESC= stdio input driver
+UUID_DESC= UUID module
+V4L_DESC= Video4Linux module
+V4L2_DESC= Video4Linux2 module
+
+.include <bsd.port.options.mk>
+
+.include "${.CURDIR}/Makefile.depends"
+
+# Port calls it GST, standard OPTION is GSTREAMER
+.if ${PORT_OPTIONS:MGSTREAMER}
+PORT_OPTIONS+= GST
+.endif
+
+.if ${PORT_OPTIONS:MSDL}
+USE_SDL= sdl sound
+.endif
+
+# SPEEX forces install of speex, therefore may as well enable all methods
+.if ${PORT_OPTIONS:MSPEEX}
+. for s in SPEEX_AEC SPEEX_PP SPEEX_RESAMP
+MAKE_ARGS+= USE_$s=yes
+. endfor
+.endif
+
+.if ${PORT_OPTIONS:MX11}
+USE_XORG= x11
+.endif
+
+.for o in ${PORT_OPTIONS}
+MAKE_ARGS+= USE_$o=yes
+BUILD_DEPENDS+= ${$o_DEPEND}
+RUN_DEPENDS+= ${$o_DEPEND}
+.endfor
+
+# GNU Make does not do make -V, which makes life difficult
+post-patch:
+ ${ECHO_CMD} >> ${WRKSRC}/Makefile
+ ${ECHO_CMD} ".PHONY: showmodules" >> ${WRKSRC}/Makefile
+ ${ECHO_CMD} "showmodules:" >> ${WRKSRC}/Makefile
+ ${ECHO_CMD} ' @${ECHO_CMD} $$(MODULES)' >> ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/share/* ${DATADIR}
+
+# Install modules and add to plist
+post-install:
+ ${MKDIR} ${PREFIX}/lib/${PORTNAME}/modules
+ for m in $$(${GMAKE} -sC ${WRKSRC} ${MAKE_ARGS} showmodules); \
+ do ${INSTALL_LIB} ${WRKSRC}/$$m.so ${PREFIX}/lib/baresip/modules; \
+ ${ECHO_CMD} lib/${PORTNAME}/modules/$$m.so >> ${TMPPLIST}; \
+ done
+ ${ECHO_CMD} "@dirrm lib/baresip/modules" >> ${TMPPLIST}
+ ${ECHO_CMD} "@dirrm lib/baresip" >> ${TMPPLIST}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/baresip/Makefile.depends b/audio/baresip/Makefile.depends
new file mode 100644
index 000000000000..5a24d242344a
--- /dev/null
+++ b/audio/baresip/Makefile.depends
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+ALSA_DEPEND= ${LOCALBASE}/include/alsa/asoundlib.h:${PORTSDIR}/audio/alsa-lib
+BV32_DEPEND= # nonexistent
+CELT_DEPEND= ${LOCALBASE}/include/celt/celt.h:${PORTSDIR}/audio/celt
+CONS_DEPEND= # unneccessary
+EVDEV_DEPEND=
+FFMPEG_DEPEND= ${LOCALBASE}/include/libavcodec/avcodec.h:${PORTSDIR}/multimedia/ffmpeg
+G711_DEPEND= ${LOCALBASE}/include/spandsp/g711.h:${PORTSDIR}/comms/spandsp
+G722_DEPEND= ${LOCALBASE}/include/spandsp/g722.h:${PORTSDIR}/comms/spandsp
+G722_1_DEPEND= # nonexistent
+GSM_DEPEND= ${LOCALBASE}/include/gsm.h:${PORTSDIR}/audio/gsm
+GST_DEPEND= gst-launch:${PORTSDIR}/multimedia/gstreamer
+ILBC_DEPEND= ${LOCALBASE}/include/ilbc/iLBC_define.h:${PORTSDIR}/net/ilbc
+L16_DEPEND=
+OPUS_DEPEND= ${LOCALBASE}/include/opus/opus.h:${PORTSDIR}/audio/opus
+OSS_DEPEND= # In base
+PLC_DEPEND= ${LOCALBASE}/include/spandsp/plc.h:${PORTSDIR}/comms/spandsp
+PORTAUDIO_DEPEND= ${LOCALBASE}/include/portaudio.h:${PORTSDIR}/audio/portaudio
+SDL_DEPEND= # Handled with USE_SDL in Makefile
+SNDFILE_DEPEND= ${LOCALBASE}/include/sndfile.h:${PORTSDIR}/audio/libsndfile
+SPEEX_DEPEND= ${LOCALBASE}/include/speex/speex.h:${PORTSDIR}/audio/speex
+SRTP_DEPEND= ${LOCALBASE}/include/srtp/srtp.h:${PORTSDIR}/net/libsrtp
+STDIO_DEPEND= # In base
+UUID_DEPEND= ${LOCALBASE}/include/uuid/uuid.h:${PORTSDIR}/misc/e2fsprogs-libuuid
+V4L_DEPEND= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
+V4L2_DEPEND= # nonexistent
+X11_DEPEND= # Handled with USE_XORG in Makefile
diff --git a/audio/baresip/distinfo b/audio/baresip/distinfo
new file mode 100644
index 000000000000..7b27de22ba72
--- /dev/null
+++ b/audio/baresip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (baresip-0.4.0.tar.gz) = e1c81730556f2cd24db94e63e4f3172892a1e8ca1047f1f506d5bbd0b436e17f
+SIZE (baresip-0.4.0.tar.gz) = 288029
diff --git a/audio/baresip/files/patch-modules-v4l-v4l-c b/audio/baresip/files/patch-modules-v4l-v4l-c
new file mode 100644
index 000000000000..8f74a4341172
--- /dev/null
+++ b/audio/baresip/files/patch-modules-v4l-v4l-c
@@ -0,0 +1,10 @@
+--- modules/v4l/v4l.c.orig 2012-09-01 17:58:40.658452422 +0100
++++ modules/v4l/v4l.c 2012-09-01 17:58:49.687451121 +0100
+@@ -7,7 +7,6 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <malloc.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
diff --git a/audio/baresip/pkg-descr b/audio/baresip/pkg-descr
new file mode 100644
index 000000000000..d0fda7313f3d
--- /dev/null
+++ b/audio/baresip/pkg-descr
@@ -0,0 +1,5 @@
+baresip is a small, modular telephony client that works
+on multiple platforms and supports several audio and video
+input/output methods.
+
+WWW: http://www.creytiv.com/baresip.html