aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp18
-rw-r--r--audio/amarok-kde4/pkg-plist4
-rw-r--r--audio/amarok/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp18
-rw-r--r--audio/amarok/pkg-plist4
4 files changed, 44 insertions, 0 deletions
diff --git a/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp b/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
new file mode 100644
index 000000000000..be021742b252
--- /dev/null
+++ b/audio/amarok-kde4/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
@@ -0,0 +1,18 @@
+--- amarok/src/mediadevice/generic/genericmediadevice.cpp.orig Mon Feb 12 23:01:20 2007
++++ amarok/src/mediadevice/generic/genericmediadevice.cpp Mon Feb 12 23:01:29 2007
+@@ -418,13 +418,7 @@
+ if( m_medium.mountPoint() == (*mountiter)->mountPoint() )
+ m_medium.setFsType( (*mountiter)->mountType() );
+ }
+- m_actuallyVfat = m_medium.fsType() ==
+-#ifdef __FreeBSD__
+- "msdosfs"
+-#else
+- "vfat"
+-#endif
+- ? true : false;
++ m_actuallyVfat = (m_medium.fsType() == "vfat" || m_medium.fsType() == "msdosfs") ? true : false;
+ m_connected = true;
+ m_transferDir = m_medium.mountPoint();
+ m_initialFile = new GenericMediaFile( 0, m_medium.mountPoint(), this );
+
diff --git a/audio/amarok-kde4/pkg-plist b/audio/amarok-kde4/pkg-plist
index 4d150af7bb7f..a76967685b24 100644
--- a/audio/amarok-kde4/pkg-plist
+++ b/audio/amarok-kde4/pkg-plist
@@ -16,6 +16,9 @@ lib/kde3/libamarok_daap-mediadevice.a
lib/kde3/libamarok_massstorage-device.so
lib/kde3/libamarok_massstorage-device.la
lib/kde3/libamarok_massstorage-device.a
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.so
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.la
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.a
lib/kde3/libamarok_nfs-device.so
lib/kde3/libamarok_nfs-device.la
lib/kde3/libamarok_nfs-device.a
@@ -1023,6 +1026,7 @@ share/locale/uk/LC_MESSAGES/amarok.mo
share/locale/uz/LC_MESSAGES/amarok.mo
share/locale/zh_CN/LC_MESSAGES/amarok.mo
share/locale/zh_TW/LC_MESSAGES/amarok.mo
+%%MTP%%share/services/amarok_mtp-mediadevice.desktop
%%NJB%%share/services/amarok_njb-mediadevice.desktop
share/services/amarokitpc.protocol
share/services/amaroklastfm.protocol
diff --git a/audio/amarok/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp b/audio/amarok/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
new file mode 100644
index 000000000000..be021742b252
--- /dev/null
+++ b/audio/amarok/files/patch-amarok_src_mediadevice_generic_genericmediadevice.cpp
@@ -0,0 +1,18 @@
+--- amarok/src/mediadevice/generic/genericmediadevice.cpp.orig Mon Feb 12 23:01:20 2007
++++ amarok/src/mediadevice/generic/genericmediadevice.cpp Mon Feb 12 23:01:29 2007
+@@ -418,13 +418,7 @@
+ if( m_medium.mountPoint() == (*mountiter)->mountPoint() )
+ m_medium.setFsType( (*mountiter)->mountType() );
+ }
+- m_actuallyVfat = m_medium.fsType() ==
+-#ifdef __FreeBSD__
+- "msdosfs"
+-#else
+- "vfat"
+-#endif
+- ? true : false;
++ m_actuallyVfat = (m_medium.fsType() == "vfat" || m_medium.fsType() == "msdosfs") ? true : false;
+ m_connected = true;
+ m_transferDir = m_medium.mountPoint();
+ m_initialFile = new GenericMediaFile( 0, m_medium.mountPoint(), this );
+
diff --git a/audio/amarok/pkg-plist b/audio/amarok/pkg-plist
index 4d150af7bb7f..a76967685b24 100644
--- a/audio/amarok/pkg-plist
+++ b/audio/amarok/pkg-plist
@@ -16,6 +16,9 @@ lib/kde3/libamarok_daap-mediadevice.a
lib/kde3/libamarok_massstorage-device.so
lib/kde3/libamarok_massstorage-device.la
lib/kde3/libamarok_massstorage-device.a
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.so
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.la
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.a
lib/kde3/libamarok_nfs-device.so
lib/kde3/libamarok_nfs-device.la
lib/kde3/libamarok_nfs-device.a
@@ -1023,6 +1026,7 @@ share/locale/uk/LC_MESSAGES/amarok.mo
share/locale/uz/LC_MESSAGES/amarok.mo
share/locale/zh_CN/LC_MESSAGES/amarok.mo
share/locale/zh_TW/LC_MESSAGES/amarok.mo
+%%MTP%%share/services/amarok_mtp-mediadevice.desktop
%%NJB%%share/services/amarok_njb-mediadevice.desktop
share/services/amarokitpc.protocol
share/services/amaroklastfm.protocol