aboutsummaryrefslogtreecommitdiff
path: root/base/binutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'base/binutils/Makefile')
-rw-r--r--base/binutils/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/base/binutils/Makefile b/base/binutils/Makefile
index 92c4e8b15338..32a5ce321ab8 100644
--- a/base/binutils/Makefile
+++ b/base/binutils/Makefile
@@ -3,6 +3,7 @@
PORTNAME= binutils
PORTVERSION= 2.33.1
PORTEPOCH= 0
+PORTREVISION= 1
CATEGORIES= base
MASTER_SITES= SOURCEWARE/binutils/releases
PKGNAMEPREFIX= ${OPSYS:tl}-
@@ -35,6 +36,7 @@ CONFIGURE_ARGS+= --disable-host-shared \
--disable-shared \
--disable-nls \
--with-system-zlib \
+ --with-sysroot="/" \
--enable-relro=no \
--enable-x86-relax-relocations=no \
--target=${BUTARGET}
@@ -117,5 +119,7 @@ post-install:
${STAGEDIR}${MANPREFIX}/man/man1/${tool}.1 \
${STAGEDIR}${PREFIX}/${BUTARGET}/bin/${tool}
.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/toolchains
+ ${INSTALL_DATA} ${.CURDIR}/files/freebsd-binutils.mk ${STAGEDIR}${PREFIX}/share/toolchains/
.include <bsd.port.post.mk>