aboutsummaryrefslogtreecommitdiff
path: root/base
diff options
context:
space:
mode:
Diffstat (limited to 'base')
-rw-r--r--base/README12
1 files changed, 12 insertions, 0 deletions
diff --git a/base/README b/base/README
index 501bf6a0e6bc..3a13d6953653 100644
--- a/base/README
+++ b/base/README
@@ -16,3 +16,15 @@ make CROSS_TOOLCHAIN=sparc64-gcc TARGET=sparc64 TARGET_ARCH=sparc64 installworld
4/ build the required port
$ cd base/binutils
make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 package
+
+$ cd base/gcc
+make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 package
+
+the package are in base/gcc/work/pkg/*.txz and base/binutils/work/pkg/*.txz
+
+To add a plist for a new binutils target
+$ cd base/binutils
+make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 makeplist > pkg-plist
+
+edit the pkg-plist and remove everything which base does not provide via the
+elftoolchain